summaryrefslogtreecommitdiff
path: root/dev-python/pexpect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /dev-python/pexpect
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest2
-rw-r--r--dev-python/pexpect/pexpect-4.9.0.ebuild25
2 files changed, 23 insertions, 4 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index fcc9f25ff493..391da4cdd0ef 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1,3 +1,3 @@
DIST pexpect-4.9.0.tar.gz 166450 BLAKE2B a08e10deb9f21e49a04021d78dc1ff6c9eeded5825ef73b236c3dac725e6877a4fe74deaa6844c8aa4b1beab4b915d7612e682529c4ed97b364a737a1960b30f SHA512 0e4b3a6978b94aee221ff23cd7bd771517e0e0f1a1a8b17f77f15bf78edd3130ad093d925b7d1e86fe6ba7eb956205d4c616b4e52b2fcfa1e944d4860dd7b3a0
-EBUILD pexpect-4.9.0.ebuild 1308 BLAKE2B a289caa84851193569c4911ed14f1dccfe8edf276ba26b482db410b1d96de70f3f31aab662db93f39532abaa36025e12c64f929ed2fa9c1e6c2de50dceb6c9ae SHA512 e334049caa493fd9f4bc677dd95ccf8da5c443f44d33d680d74b160c958b0a44da2531e82e5ef1015ea88dc19e7b896d70bfb263a1ed3acd1c4e2ef49b2d153c
+EBUILD pexpect-4.9.0.ebuild 1690 BLAKE2B 55b6b6e6130d55351dede9b2eb8f24727a63230e7c05e526af35cef48a372b9b94934c8075c60be6b95faf9e08da4c76acb86a306cbe524dbc9aeae0e4007b36 SHA512 6e417219eea9646d54b61815649ef903778fc75bd920607343b601982cc6082f2e0e2122668e00e5a13c149e7d1e0914cea7073b602c92263ae3635f779a1590
MISC metadata.xml 403 BLAKE2B 0e07f64f32ee9f6776e53f5e59b91e0e22675ebb0e8c8b98eadfb9a46d29af3e7daaafbf4e60fd7fa20bf57d42619ebdf26994b087ed0773a943acd6fddc8ab4 SHA512 4c3e18b98b69213899a6af8366ade2ebfaa4eabef76f880cd71c300b03fc7725246200bc00491942b3f7b4b4f87bdfbc9181663fe5c8b7c5325f1e7c6e76356d
diff --git a/dev-python/pexpect/pexpect-4.9.0.ebuild b/dev-python/pexpect/pexpect-4.9.0.ebuild
index 46cbdc59f88f..a12292320218 100644
--- a/dev-python/pexpect/pexpect-4.9.0.ebuild
+++ b/dev-python/pexpect/pexpect-4.9.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 pypi
@@ -33,13 +33,32 @@ src_test() {
# workaround new readline defaults
echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
local -x INPUTRC="${T}"/inputrc
+
+ distutils-r1_src_test
+}
+
+python_test() {
local EPYTEST_DESELECT=(
# flaky test on weaker arches
tests/test_performance.py
# requires zsh installed, not worth it
tests/test_replwrap.py::REPLWrapTestCase::test_zsh
+ # flaky
+ tests/test_env.py::TestCaseEnv::test_spawn_uses_env
)
- distutils-r1_src_test
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # TODO: changes in python3.13's prompt?
+ tests/test_replwrap.py::REPLWrapTestCase::test_python
+ tests/test_replwrap.py::REPLWrapTestCase::test_no_change_prompt
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
}
python_install_all() {