summaryrefslogtreecommitdiff
path: root/dev-python/pefile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pefile
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pefile')
-rw-r--r--dev-python/pefile/Manifest4
-rw-r--r--dev-python/pefile/metadata.xml21
-rw-r--r--dev-python/pefile/pefile-2021.9.3.ebuild29
-rw-r--r--dev-python/pefile/pefile-9999.ebuild29
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pefile/Manifest b/dev-python/pefile/Manifest
new file mode 100644
index 000000000000..e185c7d61758
--- /dev/null
+++ b/dev-python/pefile/Manifest
@@ -0,0 +1,4 @@
+DIST pefile-2021.9.3.tar.gz 72179 BLAKE2B a1b5390936e6c307b1d7d30f317ae77b432b17300941bfe71c4c8ed9dfecf95d623ce98eb762378ee1ff7ae938e4105e4dbcb2f6b8fe32c502b725c43b3a1154 SHA512 1960a6301823387c76e61dff73250686a32dabe009ff0410691ab9be4e57fd5f7ceca2b78302c935b74465a1e0b8faac659045c8a2be07b21dcf1baf510b1b33
+EBUILD pefile-2021.9.3.ebuild 856 BLAKE2B f8204fde291e54d945b1302c7a7c17a89a8b7a991124c7475aece43b64b3963cda90efbd0944b672bf7876474e1b282bf138d431445843b5ecbf195484ff3358 SHA512 27492df698e28b6be1845423210e3f87fec8bd7d097baf448cb3018c7fa89f437f817e6b51134b33cd68023c0c3fc1f168a16dd910e4ce8c21ccc2c0ec9120b7
+EBUILD pefile-9999.ebuild 856 BLAKE2B f8204fde291e54d945b1302c7a7c17a89a8b7a991124c7475aece43b64b3963cda90efbd0944b672bf7876474e1b282bf138d431445843b5ecbf195484ff3358 SHA512 27492df698e28b6be1845423210e3f87fec8bd7d097baf448cb3018c7fa89f437f817e6b51134b33cd68023c0c3fc1f168a16dd910e4ce8c21ccc2c0ec9120b7
+MISC metadata.xml 722 BLAKE2B f4aa26277a0e5cdb995dfbd5c8a7371ac52b935a31ef27f6a04a6bcdc1c7f46adfbb5466d340026f8221f46f46de6321951eb77a15b7e20b20dbfb8be5761caa SHA512 5379818139d4d185e3437212060c261ef1d4ac049b3c64f02b6d9d9cc68cc3be6bf80e04a83d87bb6eb9fffad18fac8f0755c71d0119bfeb125d2053dfdc0b79
diff --git a/dev-python/pefile/metadata.xml b/dev-python/pefile/metadata.xml
new file mode 100644
index 000000000000..53ac969c885d
--- /dev/null
+++ b/dev-python/pefile/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ pefile is a multi-platform Python module to parse and work with
+ Portable Executable (PE) files. Most of the information contained in
+ the PE file headers is accessible, as well as all the sections' details
+ and data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">erocarrera/pefile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pefile/pefile-2021.9.3.ebuild b/dev-python/pefile/pefile-2021.9.3.ebuild
new file mode 100644
index 000000000000..e80b72dea457
--- /dev/null
+++ b/dev-python/pefile/pefile-2021.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.
diff --git a/dev-python/pefile/pefile-9999.ebuild b/dev-python/pefile/pefile-9999.ebuild
new file mode 100644
index 000000000000..e80b72dea457
--- /dev/null
+++ b/dev-python/pefile/pefile-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.