summaryrefslogtreecommitdiff
path: root/dev-python/peewee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/peewee
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest4
-rw-r--r--dev-python/peewee/peewee-3.1.0.ebuild48
-rw-r--r--dev-python/peewee/peewee-3.13.2.ebuild2
3 files changed, 2 insertions, 52 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 0d64962043fc..a2b8b6f24c8f 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,5 +1,3 @@
-DIST peewee-3.1.0.tar.gz 705099 BLAKE2B 1dc528082337ae509fc9f91c521d7bf036179ad6b1a5a93e113d594ce819d3a9cdbb7e687b51acacdaf242d542dad138ce2a21f9dcc19483c7361788329a53ed SHA512 628eea27d51017a6ab87aae9ae851d749b0f437fe1806957b23408ad3c97bbb93e5b84c66c5e70bfb7b55c9f29a0c517b84e65adc0f979da450987d670661e84
DIST peewee-3.13.2.tar.gz 871323 BLAKE2B 18fd9729ddd6ce3fe4a6963b697815d44e91b5078ba0b868e6b4f24f4cec9c5b01239d7f414f4f8c0871d3dc6bd5e0e37e218c9438cf1f7461bf729cb74049e4 SHA512 7304473f8e64df7cb2205900cfbdd52346d89e9639dc79ed6e13d5c4c11cc856e39e366772039097dc5ca86b4768fa4670dccd96a85cabfb522c463b31c40a8b
-EBUILD peewee-3.1.0.ebuild 1267 BLAKE2B 76a05179c1e6a643ce481d55f42eed67eede342a713e1f17aaf73651e432920691ef4c7585a1bdd53df6b0bdda0476b8d0e087f3b2f8d19f85d90035d8f389fc SHA512 00b639532ccff586496e8273bae51007ccf3ac9150366e56fbe559cba54247e543b59148246e7e847036409959fdef4a7aba2f52f879c0700a5ee34a038517f6
-EBUILD peewee-3.13.2.ebuild 758 BLAKE2B 7cbcf63dcfe86da18979d1cd0a65c3ca72af56c405c113d8be1865c68555d6f7da80f29b8f9e46e5db5efa82e89abc9aed2ed6b45dc8f31c21c0a6559982dd65 SHA512 fbc9acf13b3e7fb9b003f68732b080d1f041026f46eeba7318b751bbb4f5a80054dc2cdd32b09ef3ea14890add586858b9020a09df1dae9fe27398b98df93e2a
+EBUILD peewee-3.13.2.ebuild 757 BLAKE2B c9df37e300014ba2926e1e33b6e4e5b8d50b04bb31687ff4dfd21d84da7faa0d7cb843970ccbc817ea52750e97cd8a351ce7c56d6fe0c003312a8a9c53d39004 SHA512 8255962995c158f633702a8d661c80adb7a71e03f630cd39c6297ac863833f2b87649e2fee6a10146e799ced0040fdc9746640d1dc79e8a186c68782f83ef0c6
MISC metadata.xml 330 BLAKE2B 744abc7ba6933e67a2e85359c870e51ed2e5b39cde3adf64a4e92860805eefc37e8035000b1728a921816e0713c8757f0fbcb40206b72505117b2bead9ed2642 SHA512 a75ad6963c2dd0a763e7f11b42a5f92d536a7b4daf59acea56a91b49c11996d316d3fc27b04fcba9c4e7556305543eb44d87ac909a65f937faaf8fd8c57110b2
diff --git a/dev-python/peewee/peewee-3.1.0.ebuild b/dev-python/peewee/peewee-3.1.0.ebuild
deleted file mode 100644
index 78dda8ee3b05..000000000000
--- a/dev-python/peewee/peewee-3.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-DEPEND="dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- sed -i -e "s#test_suite='tests',##g;" ./setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Testsuite run using runtests.py does not require deps listed in previous ebuild
- "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && DOCS=( examples/ )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/peewee/peewee-3.13.2.ebuild b/dev-python/peewee/peewee-3.13.2.ebuild
index d1d51cbabc26..e05e6b58b532 100644
--- a/dev-python/peewee/peewee-3.13.2.ebuild
+++ b/dev-python/peewee/peewee-3.13.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1