summaryrefslogtreecommitdiff
path: root/dev-python/peewee/peewee-3.16.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
commit24a48769f03b243065aec42c384c39a2d2306964 (patch)
tree6ee4e01247ea4cbdae0b2c9e6b88d86658fae0d3 /dev-python/peewee/peewee-3.16.0-r1.ebuild
parent87f37a073fb5c2e1f6ebc780e60cdbdd2c583860 (diff)
gentoo auto-resync : 28:02:2023 - 10:03:37
Diffstat (limited to 'dev-python/peewee/peewee-3.16.0-r1.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.16.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-3.16.0-r1.ebuild b/dev-python/peewee/peewee-3.16.0-r1.ebuild
new file mode 100644
index 000000000000..b2e1e7d16ff7
--- /dev/null
+++ b/dev-python/peewee/peewee-3.16.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-db/sqlite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}