summaryrefslogtreecommitdiff
path: root/dev-python/pebble/pebble-5.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
commitbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (patch)
tree4a2377c9096a6e85935bc1b24a50c09537fbb3ca /dev-python/pebble/pebble-5.0.2.ebuild
parentf69024d0d689548234c6173dc2d8a5bb466b0525 (diff)
gentoo auto-resync : 10:10:2022 - 13:34:00
Diffstat (limited to 'dev-python/pebble/pebble-5.0.2.ebuild')
-rw-r--r--dev-python/pebble/pebble-5.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pebble/pebble-5.0.2.ebuild b/dev-python/pebble/pebble-5.0.2.ebuild
new file mode 100644
index 000000000000..b1830f4e238c
--- /dev/null
+++ b/dev-python/pebble/pebble-5.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble/
+ https://pypi.org/project/Pebble/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest