summaryrefslogtreecommitdiff
path: root/dev-python/pdoc3/pdoc3-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 23:21:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 23:21:12 +0100
commit979898cb45139dd0e6727a01df15b602f74a8dd3 (patch)
tree6c18ca0165dc1a0477e0c9c9253c98f03f26da67 /dev-python/pdoc3/pdoc3-0.10.0.ebuild
parent09f46eb2a6639c039b0b4268a8410d93bbf14e9e (diff)
gentoo auto-resync : 03:04:2023 - 23:21:12
Diffstat (limited to 'dev-python/pdoc3/pdoc3-0.10.0.ebuild')
-rw-r--r--dev-python/pdoc3/pdoc3-0.10.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pdoc3/pdoc3-0.10.0.ebuild b/dev-python/pdoc3/pdoc3-0.10.0.ebuild
deleted file mode 100644
index 057bb057cb39..000000000000
--- a/dev-python/pdoc3/pdoc3-0.10.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Auto-generate API documentation for Python projects"
-HOMEPAGE="https://pdoc3.github.io/pdoc/"
-
-SLOT="0"
-LICENSE="AGPL-3+"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/markdown-3.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-TST-use-explicit-ClassWithNew-instead-of-typing.Gene.patch"
-)
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- sed -i \
- -e "/setuptools_git/d" \
- -e "/setuptools_scm/d" \
- setup.py || die
-}
-
-distutils_enable_tests unittest