summaryrefslogtreecommitdiff
path: root/dev-python/pdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-17 14:06:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-17 14:06:19 +0000
commitfc6e577018dec28e18904f9ad5c1417976e3c728 (patch)
treed1bffe78e4c3db88c10e85e3efd2f7e2c0e5a156 /dev-python/pdm
parente74bddc195533f6d160ee96220f5cfcc205bda1c (diff)
gentoo auto-resync : 17:01:2024 - 14:06:19
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest2
-rw-r--r--dev-python/pdm/pdm-2.12.1.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 93ae51cb36a6..5188b68eb10d 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,5 +1,7 @@
DIST pdm-2.11.1.tar.gz 2595425 BLAKE2B cebaf5a86045a9826a8d6a77985a064fe3e05af403818a4629f7a978a58a4fd07e4d12ba4a69542cd4cf2a090d28a826ebadf0d703543b0551f49b61039d6d38 SHA512 e62bd64b1b302bffe0f7f18a68244b108a10969108ce98df028bd56662b336db8bf019fb1d516cc1dc579b838c674ef8601b8f7056e8547a89c5d3311cd037d9
DIST pdm-2.11.2.tar.gz 2595716 BLAKE2B 10d1c78160f45099cdbbac6f6ef402b4c9f892e229fe56e54f164b4d7c3317cc8808639b97990e9fefda879d693cba32b48fc7b4c787704e7893c0844351227f SHA512 f27c1b5704469cc846b21a090f2098dacd486b833093af661644717a6dd6cdc627b086027b1c71037d5f3b179e72eac6dde3a98320eaff4f033ae9c96b37ab2c
+DIST pdm-2.12.1.tar.gz 2598220 BLAKE2B 3aa7ea827b4f38398c8e20ea06d887add3c87c5df26acf627580278eb87ddf508fe7eb03a83ea726541f1233168eb7975dc03715673dffb8d9f30d2843765c6f SHA512 2837f96de13e4d91f0cfe1b632c1fa08d27ce44230c43933e2cf2af2f4b9f3986719104ebc8e3f250f6a005e2a97428d580af0626b55b1e6c2f8f72c14ef67cf
EBUILD pdm-2.11.1.ebuild 2712 BLAKE2B d47e697c77ce58da6f7d628694a96ec7534b36cab5974be6613be4d515c8e847a44be31df074288b28318bbc0228503beb86ae0227ad4ce740930a003f3e60a6 SHA512 809ac800f8231d092a52c0a6a98327839ce8a471a3cd5af2932b3e7a16951a1e43bed43453e38746ea59c9de43fff2b02269776f7c2f0d685531df43667fe850
EBUILD pdm-2.11.2.ebuild 2701 BLAKE2B 3fb9bd26ddf5a8b28bcc87f3bde500b9301bbb5f3782bb04ab309cf3107b188566f16c7c12cba6e8f833f4f10a8413cf9ede13f8d3b8d34c0e0cc363868171ee SHA512 e6fa3ba598008e041f293fba99cf9b9cfb1e060cd2d5693c384e0c331484e3eb1679d834c88a8451b7d3b55a6593f6682a4f521f3c3bec08bffb18c0b1d86d62
+EBUILD pdm-2.12.1.ebuild 2701 BLAKE2B 3fb9bd26ddf5a8b28bcc87f3bde500b9301bbb5f3782bb04ab309cf3107b188566f16c7c12cba6e8f833f4f10a8413cf9ede13f8d3b8d34c0e0cc363868171ee SHA512 e6fa3ba598008e041f293fba99cf9b9cfb1e060cd2d5693c384e0c331484e3eb1679d834c88a8451b7d3b55a6593f6682a4f521f3c3bec08bffb18c0b1d86d62
MISC metadata.xml 474 BLAKE2B c1471e124a955920e30f73dfa43a87999c30c2bb9615590f601befcc07f7d939ec68908e67c7345fca4cb0f0524d33507aeac9936fa30d449d1dde17094048d3 SHA512 a07256061dda5a8cf8b0e15205ac36651a4e5b594fdedbfe16d1d3264e1ac42847d1dc222d2857232ac5206d67feda432751695d85d0c4c7b03fd7228db8b1ab
diff --git a/dev-python/pdm/pdm-2.12.1.ebuild b/dev-python/pdm/pdm-2.12.1.ebuild
new file mode 100644
index 000000000000..170c13d740d0
--- /dev/null
+++ b/dev-python/pdm/pdm-2.12.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pdm-project.org/
+ https://github.com/pdm-project/pdm/
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/dep-logic-1.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/truststore[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.12.1[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock
+}