summaryrefslogtreecommitdiff
path: root/dev-python/pdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-27 10:33:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-27 10:33:45 +0100
commita12f416baa722b8bda57c0d527fb28b3d06b2aeb (patch)
tree00347496d39521fc572cc53fbd17037fbe73ca06 /dev-python/pdm
parentef27446dc21d9fb7ee400987661cb759f6a6ee85 (diff)
gentoo auto-resync : 27:07:2023 - 10:33:45
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest2
-rw-r--r--dev-python/pdm/pdm-2.8.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index f81b3db7056d..7613429cc45a 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,3 +1,5 @@
DIST pdm-2.8.0.tar.gz 3069029 BLAKE2B 3fc3246c7bf26953be96def58d8249c981def96e1607b82b35f1b8347dc5246dd6b4613e4f2093e2e6453724e8709951d2fff38a1f02f2dcc5e85fe6e8c678da SHA512 95cc0a4cb032fa39281aea5ab2f31da7f503c6444a9c41d88ac9bf9ab650654a3f154506f2ed822e70266046c4b6a111518ed68aa7ab75aa31c096e071859bcd
+DIST pdm-2.8.1.tar.gz 3014347 BLAKE2B 0dde8e2376065ac6241e06c24a7b1b241e5653f6e2cb7fd529cc8dfd3d0f6c6fc4c6a43208551594a7d837d11dbaff02612d944a9077cb132d3eee3c23559ee7 SHA512 f18fddd533cf0b72f9ff376c865bc5df6a58c248f4c9737404eb1d62f5d9a233f22b7a76db3b2f9b7a321c8d1e3aa2ea395d2dd3ffe29834ccc09c8272410b82
EBUILD pdm-2.8.0.ebuild 1809 BLAKE2B 8a58008f56e6eeef3f60917e159ac45905b63b7e2c040cf800055453ab3b583bed7d35ff07faaf5dc9b922b362213a0cd63701bde842468c7ffb57da1e67c3d7 SHA512 221d148fe6ee7744fe65f2aca503cd8e7bd0bf0242a54fa2b2e95fedc96d99a4c98e1f6832dd919cc281932f6a323ed01cb483810caa588d0a897074ca8ad7b2
+EBUILD pdm-2.8.1.ebuild 2243 BLAKE2B 793f8516d6f341fecb38d0f4f02d43290c600b67fcb7e6f9b0fabb7688a5d10d518760e21721d4731704a7eecab605eaa7cedddc79866a5d816639db65cc477b SHA512 0adae8c6ccc867216928457c705c24f0ecbf2d3b4ebb1e5c2f53968beac3379dd6aed8741d78b79e9b545891bcdf8eb57cc22f17616af828d51a83058d438d76
MISC metadata.xml 419 BLAKE2B 4bb9d30f2274bd258d27da17271a172860c6475f18d8898827347853bd5c0a27ef2be17e7183a4e825a3e15678c1c69da0c3aa12f1df18ca6d62e97fe788660d SHA512 6810c73f34329c8a16295ff0e21157a05eb538df564f43c4829f6cffdbd2bf0a224462fc69ebe11c70a94305168d9930c28896db9894d599a014140663b164d5
diff --git a/dev-python/pdm/pdm-2.8.1.ebuild b/dev-python/pdm/pdm-2.8.1.ebuild
new file mode 100644
index 000000000000..281812e00468
--- /dev/null
+++ b/dev-python/pdm/pdm-2.8.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.10.0[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ )
+
+ epytest -m "not network and not integration and not path"
+}