summaryrefslogtreecommitdiff
path: root/dev-python/pdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 02:49:03 +0100
commit293b7d4c34fb5285799bb5149595e29dae34cac9 (patch)
treeea6bb71bb2bbdb570695963f3127e5299e1ce1ba /dev-python/pdm
parent1e3cb587fdf303df9aeb0b00a1a45585e18f6134 (diff)
gentoo auto-resync : 22:07:2023 - 02:49:03
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest3
-rw-r--r--dev-python/pdm/metadata.xml15
-rw-r--r--dev-python/pdm/pdm-2.8.0.ebuild69
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
new file mode 100644
index 000000000000..f81b3db7056d
--- /dev/null
+++ b/dev-python/pdm/Manifest
@@ -0,0 +1,3 @@
+DIST pdm-2.8.0.tar.gz 3069029 BLAKE2B 3fc3246c7bf26953be96def58d8249c981def96e1607b82b35f1b8347dc5246dd6b4613e4f2093e2e6453724e8709951d2fff38a1f02f2dcc5e85fe6e8c678da SHA512 95cc0a4cb032fa39281aea5ab2f31da7f503c6444a9c41d88ac9bf9ab650654a3f154506f2ed822e70266046c4b6a111518ed68aa7ab75aa31c096e071859bcd
+EBUILD pdm-2.8.0.ebuild 1809 BLAKE2B 8a58008f56e6eeef3f60917e159ac45905b63b7e2c040cf800055453ab3b583bed7d35ff07faaf5dc9b922b362213a0cd63701bde842468c7ffb57da1e67c3d7 SHA512 221d148fe6ee7744fe65f2aca503cd8e7bd0bf0242a54fa2b2e95fedc96d99a4c98e1f6832dd919cc281932f6a323ed01cb483810caa588d0a897074ca8ad7b2
+MISC metadata.xml 419 BLAKE2B 4bb9d30f2274bd258d27da17271a172860c6475f18d8898827347853bd5c0a27ef2be17e7183a4e825a3e15678c1c69da0c3aa12f1df18ca6d62e97fe788660d SHA512 6810c73f34329c8a16295ff0e21157a05eb538df564f43c4829f6cffdbd2bf0a224462fc69ebe11c70a94305168d9930c28896db9894d599a014140663b164d5
diff --git a/dev-python/pdm/metadata.xml b/dev-python/pdm/metadata.xml
new file mode 100644
index 000000000000..dc753739c79d
--- /dev/null
+++ b/dev-python/pdm/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pdm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pdm/pdm-2.8.0.ebuild b/dev-python/pdm/pdm-2.8.0.ebuild
new file mode 100644
index 000000000000..af490a26b277
--- /dev/null
+++ b/dev-python/pdm/pdm-2.8.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/unearth[${PYTHON_USEDEP}]
+ dev-python/findpython[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -a disable_tests=(
+ # tests that try to reach out to the internet
+ basic_integration
+ build_with_no_isolation
+ search_package
+ show_package_on_pypi
+ show_update_hint
+ build_single_module
+ project_packages_path
+ build_package
+ build_src_package
+ build_with_config_settings
+ cli_build_with_config_settings
+ build_ignoring_pip_environment
+ publish_and_build_in_one_run
+ )
+
+ local textexpr
+ testexpr=$(printf 'not %s and ' "${disable_tests[@]}")
+ epytest -m "not network and not integration and not path" -k "${testexpr%and }" -x
+}