summaryrefslogtreecommitdiff
path: root/dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-12 11:41:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-12 11:41:02 +0100
commitd15be4fe2ff3e70717117a938dbe5a11cec60a7b (patch)
tree11b55e9435c5d885c195338bb42507d74636c34c /dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild
parent81663ab80e0e0c5839b216934509b6bcbf08429a (diff)
gentoo auto-resync : 12:04:2023 - 11:41:02
Diffstat (limited to 'dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild')
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild b/dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild
new file mode 100644
index 000000000000..dcddfcb21ab1
--- /dev/null
+++ b/dev-python/pdm-pep517/pdm-pep517-1.1.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+# upstream has renamed the repo but the legacy branch is still published
+# as pdm-pep517, sigh
+MY_P=pdm-backend-${PV}
+DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
+HOMEPAGE="
+ https://pypi.org/project/pdm-pep517/
+ https://github.com/pdm-project/pdm-backend/
+"
+SRC_URI="
+ https://github.com/pdm-project/pdm-backend/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+# setuptools are used to build C extensions
+RDEPEND+="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r pdm/pep517/_vendor || die
+ find -name '*.py' -exec sed \
+ -e 's:from pdm\.pep517\._vendor\.:from :' \
+ -e 's:from pdm\.pep517\._vendor ::' \
+ -i {} + || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "Test User" || die
+ distutils-r1_src_test
+}