summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/pbr
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/pbr-5.6.0.ebuild19
2 files changed, 6 insertions, 15 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 8f4e80de2fe5..00c285ac4e61 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,3 +1,3 @@
DIST pbr-5.6.0.tar.gz 125220 BLAKE2B fc26737857195b0dbe16ecbcbc6e389b53a61105b3bc66e714bb4fcb4907e4329ee7c76b5748fa7d892bf231522e6ff9d414328ae0d97e6262b608c44c737764 SHA512 1dca9020a84e3b9be71fa07e2feb37bbdb2bb69d0b4f69fdcee0fc3c7fe4d84ac2e2079d6bd7560192833f069ca6f5dc27d03a3ef87c168eed18eee8579647fc
-EBUILD pbr-5.6.0.ebuild 2300 BLAKE2B 073cf980c49f7476b4a1f2a79c31f5888690dbab5cea77c1abffff940949214519663dba49f58becd519b8def6a415d6c365fcb89009cd5f6e335d78a9d81a30 SHA512 bdcb1a4f0061597396915a6dc2151054597de824440afd95e0ee786ad9ff8c8ab21770b6a23bf873ab130aaf19f28fce1b20ebddd445d4852833ef4a0d27be5d
+EBUILD pbr-5.6.0.ebuild 1975 BLAKE2B 2494ab7dcd8d4be97e4ea2b467fb33561174e8a098f3794cc21efcc25193decbc1b8f6dc78ffaa75ac2bc10f5de004586d5872803b7b483e44514b3483f62c39 SHA512 88b653436202c318418e99dd96870326d04c011d5a12c84904781f77219818d31ab45689ec8b1c67fbca1539618892a007b783f7aa10d65ea76be09a6b748b5f
MISC metadata.xml 814 BLAKE2B ca519dee02f08350185d53773b1c90724c92c7c814025417b295cf0ad961064d26323830ee19f78416bd6fc67b43517736d51bf485c4d314c9313ca4c420a6dd SHA512 0c0b2f916a99a568c224cce64636f513bc7d8bb2c7ddf690f55eb46d5b98afd0060a5db74a8515277e84dc5c08d8d5754a37eae73b1fdb3460cf1d45b5797e88
diff --git a/dev-python/pbr/pbr-5.6.0.ebuild b/dev-python/pbr/pbr-5.6.0.ebuild
index a59c1d35b29b..7c12cac8e10d 100644
--- a/dev-python/pbr/pbr-5.6.0.ebuild
+++ b/dev-python/pbr/pbr-5.6.0.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..9} pypy3 )
PYTHON_REQ_USE="threads(+)"
-
inherit distutils-r1
DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
@@ -16,8 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
@@ -34,11 +30,11 @@ BDEPEND="
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.1.0[${PYTHON_USEDEP}]
dev-vcs/git
' 'python*')
)"
-PDEPEND=""
+
+distutils_enable_tests unittest
# This normally actually belongs here.
python_prepare_all() {
@@ -56,16 +52,11 @@ python_prepare_all() {
}
python_test() {
- if [[ ${EPYTHON} == pypy3 ]]; then
+ if [[ ${EPYTHON} != python* ]]; then
einfo "Testing on ${EPYTHON} is not supported at the moment"
return
fi
distutils_install_for_testing
- local -x PATH=${TEST_DIR}/scripts:${PATH}
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- stestr init || die "stestr init failed under ${EPYTHON}"
- stestr run || die "stestr run failed under ${EPYTHON}"
+ eunittest -b
}