summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pbr
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest4
-rw-r--r--dev-python/pbr/pbr-5.8.0-r1.ebuild (renamed from dev-python/pbr/pbr-5.8.0.ebuild)3
-rw-r--r--dev-python/pbr/pbr-5.9.0.ebuild69
3 files changed, 75 insertions, 1 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index ade49bd7fcdb..b041ddd3e94a 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,3 +1,5 @@
DIST pbr-5.8.0.tar.gz 127170 BLAKE2B 7fbd166f01617617c0dff568d1bb88a4be03d62f4f0c3ca1a7d16a7cefb20dcc924ffbb8df0d2d34516cfe3b60b8e380a0eb4a1071220bb4ab695d3d7c88d824 SHA512 61a8eb63bb76ce8515c4203d60df7c973e02ea61b603d155b611724efb2b15c42416bf8a0285451d3378056d390bbf63d991cec32cc4114ae5cc30ebae0a5a69
-EBUILD pbr-5.8.0.ebuild 2154 BLAKE2B de3b602d27ea8be70787819ad1cbba5b497aa666533379fa2073f9b30e84f69c033540f6ee1bd4ce18dd4b51d708c9a5c24c5cdf042dcd289e75f7af6f17a693 SHA512 2047098d32668d2877f654d460b3b3082a14e9a1d91a9c61a10f1449bca3ef542f979cc02a959c4f961c2d8c62b718aa46e173767430416bfd4d749747045de2
+DIST pbr-5.9.0.tar.gz 126893 BLAKE2B 3f1d39c037afa7fe6d45b0b039968243e99717b347d1f1ada25023a64e7e683c0d83d2ce177e0f7c5f4cb65cd2a0eedd594b463d5d72bdc86560d811bd3f0cd3 SHA512 b36cc331664b91899a884bb1bc6980174ba2463db35c591d480d0b5a49dd37781132893e488c6a9238fbd2ec16589652d66b01a8c2701d02ff5c0b04e9c6121b
+EBUILD pbr-5.8.0-r1.ebuild 2216 BLAKE2B 80b0812a8b02ada55321ca9964224aac42cc58f1189113752cf1368825d218f780c71625f374809f2010a67e466b4e6aa7f3858ac54dc1ebca8c3dae2e68e162 SHA512 d486283f6940cb96fe31c3a51448ed9d3f83c300d4e930661f36ff034c2c7ccb7d2d76ba4fd4f13cf8b10b5d93f4376dbaa34f562953fb542ba526f06098ebcf
+EBUILD pbr-5.9.0.ebuild 2225 BLAKE2B 8df13f9f3b0610a4cbffd26459d2ae023ef5c5c033d2b1efec0dff54be5789f32c3c2c85a8466af34af1e753624fa5c5429905288348e027ed67c25285c4141e SHA512 cd290db95a44fb40f1d9b681752083c71b53d881a12b3850421f2855c12b97e793fa349a69f88859493c01bd993d6939286b499098e467065d442b2be9b6b42d
MISC metadata.xml 815 BLAKE2B 439ee90d79572a8653f1ae3b8b5bf0883adb34ceac5257458dba7a2505e25ebba1c5080095139f6521d8fbd57c11ea38cf4049710b584069aea0ebaa7760077a SHA512 3d0618ef6656706acd829be80b2e6a0b0763b5f4128dcd360f28818d42cbc8825ecd04f7f47af5929a3a35fd60a3b9f9816cc37ee30af164c2e5b51764c25afe
diff --git a/dev-python/pbr/pbr-5.8.0.ebuild b/dev-python/pbr/pbr-5.8.0-r1.ebuild
index 0e9948c5a3f6..0c4254d5cca3 100644
--- a/dev-python/pbr/pbr-5.8.0.ebuild
+++ b/dev-python/pbr/pbr-5.8.0-r1.ebuild
@@ -15,6 +15,9 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+RDEPEND="
+ >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
+"
# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
# stestr is run as external tool
diff --git a/dev-python/pbr/pbr-5.9.0.ebuild b/dev-python/pbr/pbr-5.9.0.ebuild
new file mode 100644
index 000000000000..c78b5363efe1
--- /dev/null
+++ b/dev-python/pbr/pbr-5.9.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack/pbr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
+"
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' 'python*')
+ )"
+
+distutils_enable_tests unittest
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # TODO: investigate
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ # broken on pypy3
+ # https://bugs.launchpad.net/pbr/+bug/1881479
+ sed -e 's:test_generates_c_extensions:_&:' \
+ -i pbr/tests/test_packaging.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+ # installs random packages via pip from the Internet
+ sed -e 's:test_requirement_parsing:_&:' \
+ -e 's:test_pep_517_support:_&:' \
+ -i pbr/tests/test_packaging.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} != python* ]]; then
+ einfo "Testing on ${EPYTHON} is not supported at the moment"
+ return
+ fi
+
+ eunittest -b
+}