summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 14:02:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 14:02:42 +0100
commit5560910b8e280aa828f26c34b4e361b44f5227c4 (patch)
tree2abdaf1f2d47833722c546232baa3780b006df0d /dev-python/pbr
parentf1269e587f3d88b85f72a6fbaf727da5d6c9af90 (diff)
gentoo auto-resync : 21:10:2022 - 14:02:42
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/pbr-5.11.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 02766bd79718..3facbfe0057a 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,3 +1,5 @@
DIST pbr-5.10.0.tar.gz 127122 BLAKE2B 45a254629c2d1e73ce500edb5ba05f165dfaa9987bd62500490cdcceed11708878bc82441f218cf2f5a38b50301a2bcd0aabd0a5e5810346586d8d6463162ba9 SHA512 a5f4393407a17f4de5977483f3c7fa651780b9b9069a0a1898a5b511742262dfb06f891cfcb632c5b64ecfd041188095ceb880c6e71c99c81f0eace59e4e1976
+DIST pbr-5.11.0.tar.gz 127505 BLAKE2B 201fcd04ded1f909f4792886ddf79a5a764318645ff6b6245543cde2940d502ab711820cb6e999894a339df933e43e6a8394bd8ec1e978d930710a3085b131fd SHA512 bdb442e8ef7bda90a65c5fb7f0696041808278fcc643eb0c15d5401b7da7d64cd3566018b1046145f55bc5683791ee182bec92461801004b02a35b8bf4c5abf0
EBUILD pbr-5.10.0.ebuild 2178 BLAKE2B 0e64b677e735c6ca41e130e3b24123eb575d65d8c500a479dfb294ffaf5586f81f905b07145db5a11f1837102efcf890356d1e19a30775a5e11f0e4c49009eee SHA512 dff96e665e547523584351cc1e6bcaee5f15e98850760ae2aa47b7a8450c51680b0c5817854bcb7fea97c82be8fd3eaafc9653e68dab67f6ef77de592e6a4184
+EBUILD pbr-5.11.0.ebuild 2187 BLAKE2B 15aa68efbd3ce5981e2c5b9e0d76cd0bfdb6c91eb94bcc0a69c66ac3a8ef51e978a622522d14d91ae762d5c9e25ebb8e5efec98dc184bb4763b66d3e6bccd769 SHA512 c5f5b48e03f2a73e89904b1bfdf20c806cc270c83da7299a327eba246b56e8cec64635d8a8070dc74c055c13c02e83254b3ec9365730b213eee2fc9279415ad2
MISC metadata.xml 815 BLAKE2B 439ee90d79572a8653f1ae3b8b5bf0883adb34ceac5257458dba7a2505e25ebba1c5080095139f6521d8fbd57c11ea38cf4049710b584069aea0ebaa7760077a SHA512 3d0618ef6656706acd829be80b2e6a0b0763b5f4128dcd360f28818d42cbc8825ecd04f7f47af5929a3a35fd60a3b9f9816cc37ee30af164c2e5b51764c25afe
diff --git a/dev-python/pbr/pbr-5.11.0.ebuild b/dev-python/pbr/pbr-5.11.0.ebuild
new file mode 100644
index 000000000000..1e521c028037
--- /dev/null
+++ b/dev-python/pbr/pbr-5.11.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{8..11} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="
+ https://opendev.org/openstack/pbr/
+ https://github.com/openstack/pbr/
+ https://pypi.org/project/pbr/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
+"
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # TODO: investigate
+ sed -e 's:test_console_script_develop:_&:' \
+ -e 's:test_console_script_install:_&:' \
+ -e 's:test_setup_py_keywords:_&:' \
+ -i pbr/tests/test_core.py || die
+ # network
+ rm pbr/tests/test_wsgi.py || die
+ # installs random packages via pip from the Internet
+ sed -e 's:test_requirement_parsing:_&:' \
+ -e 's:test_pep_517_support:_&:' \
+ -i pbr/tests/test_packaging.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Testing on ${EPYTHON} is not supported at the moment"
+ return
+ fi
+
+ eunittest -b
+}