summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/pbr
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/pbr-5.8.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index a39f1b42cab0..d1790bf2ffe8 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,5 +1,7 @@
DIST pbr-5.6.0.tar.gz 125220 BLAKE2B fc26737857195b0dbe16ecbcbc6e389b53a61105b3bc66e714bb4fcb4907e4329ee7c76b5748fa7d892bf231522e6ff9d414328ae0d97e6262b608c44c737764 SHA512 1dca9020a84e3b9be71fa07e2feb37bbdb2bb69d0b4f69fdcee0fc3c7fe4d84ac2e2079d6bd7560192833f069ca6f5dc27d03a3ef87c168eed18eee8579647fc
DIST pbr-5.7.0.tar.gz 126776 BLAKE2B ff41c0b3d2354dff065bda4dc9278e42d06accc9fab96bdd734cb462682caf240d1e5d3a6e6c1f52c2986f92d4a1b11b74f5d563a9e8bd5e75aaafe7c3b30108 SHA512 076e6f918db46df74688e749242331161b858def6135d4c9695c24cdfe7db3185169787a6d5555a40a9d0e87ea54000be6419701f162283047bee41f36811535
+DIST pbr-5.8.0.tar.gz 127170 BLAKE2B 7fbd166f01617617c0dff568d1bb88a4be03d62f4f0c3ca1a7d16a7cefb20dcc924ffbb8df0d2d34516cfe3b60b8e380a0eb4a1071220bb4ab695d3d7c88d824 SHA512 61a8eb63bb76ce8515c4203d60df7c973e02ea61b603d155b611724efb2b15c42416bf8a0285451d3378056d390bbf63d991cec32cc4114ae5cc30ebae0a5a69
EBUILD pbr-5.6.0.ebuild 1976 BLAKE2B 8790776541e448548b3ab6a331f76ec7dc6767fe5ddb0d26326cd179096774c5461f24082ee94cdc0a4c628b72ec7ea726056312c0cb21a9a83ee15b05980aeb SHA512 1403c13b5a0fc8be2c429568c4c6a5026c016b018f3b18cb5d92a2a87759ee74e5ffd030da6b1b482c3a44923af619a31c65675385cb121af92edac7c2ca662d
EBUILD pbr-5.7.0.ebuild 2156 BLAKE2B 8884d0e6573719f22c9e6737a03678ed0ac7204f30b788bfa1a5f360f01a86425342b9d1c9fe7f34cbe1c60664e196528eb663ec76b4879b1f4a5b49d41c6a77 SHA512 55e0ef2c1a34a1797323e69534f3b9d9d7bb0d27c67ec3145ee4177a8c35795966c8d154f0c97b2d6c6d13d0451d776ce049fd0621e62f9b658eeb9ca3f211e6
+EBUILD pbr-5.8.0.ebuild 2156 BLAKE2B 8884d0e6573719f22c9e6737a03678ed0ac7204f30b788bfa1a5f360f01a86425342b9d1c9fe7f34cbe1c60664e196528eb663ec76b4879b1f4a5b49d41c6a77 SHA512 55e0ef2c1a34a1797323e69534f3b9d9d7bb0d27c67ec3145ee4177a8c35795966c8d154f0c97b2d6c6d13d0451d776ce049fd0621e62f9b658eeb9ca3f211e6
MISC metadata.xml 815 BLAKE2B 439ee90d79572a8653f1ae3b8b5bf0883adb34ceac5257458dba7a2505e25ebba1c5080095139f6521d8fbd57c11ea38cf4049710b584069aea0ebaa7760077a SHA512 3d0618ef6656706acd829be80b2e6a0b0763b5f4128dcd360f28818d42cbc8825ecd04f7f47af5929a3a35fd60a3b9f9816cc37ee30af164c2e5b51764c25afe
diff --git a/dev-python/pbr/pbr-5.8.0.ebuild b/dev-python/pbr/pbr-5.8.0.ebuild
new file mode 100644
index 000000000000..a36a0e075381
--- /dev/null
+++ b/dev-python/pbr/pbr-5.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack/pbr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' 'python*')
+ )"
+
+distutils_enable_tests unittest
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # TODO: investigate
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ # broken on pypy3
+ # https://bugs.launchpad.net/pbr/+bug/1881479
+ sed -e 's:test_generates_c_extensions:_&:' \
+ -i pbr/tests/test_packaging.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+ # installs random packages via pip from the Internet
+ sed -e 's:test_requirement_parsing:_&:' \
+ -e 's:test_pep_517_support:_&:' \
+ -i pbr/tests/test_packaging.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} != python* ]]; then
+ einfo "Testing on ${EPYTHON} is not supported at the moment"
+ return
+ fi
+
+ distutils_install_for_testing
+ eunittest -b
+}