summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
commit06dcf64674a43718324bffee383625d2cd050b75 (patch)
tree4de58e857f3f0718fef4fc386e42577c2f4c9478 /dev-python/pbr
parent198bd0cd3c1be97f7deb5283fa00048718482de4 (diff)
gentoo auto-resync : 07:11:2023 - 22:21:54
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/pbr-6.0.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 1614a5e2f1a4..b3fdba49805e 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,5 +1,7 @@
AUX pbr-5.11.1-importlib-suffixes.patch 1383 BLAKE2B a8931bfe53a6609479de4eaa27a9ed28bd59319f79cf80dbe8f2578783cc6b57d641ca2c014793546efd52615ba4343a2a09527973107568c983c431329566d5 SHA512 537cdcb21e4f104731327f92d2af0b478fa9cdee792eff206f51ef59e473252c6f1ed6eeba7105b57ea6759d43ce8b4de51f61689a5b1585920ed46a1a675e33
AUX pbr-5.11.1-sphinx-tests.patch 1281 BLAKE2B a39328c0071d78ba9ec654ad198161522e5866a7627cbe7995290b44d70bb913dc5b3e335b8445b804ee7e1aa4c71bdebf5b5f60f943cfff0a4f91fdb50a0b59 SHA512 83d5301a4379d71672fd2870d827c40a4517283794029672d0f6be26a01020a5e0aae9f6ead91725dba682fffcba8ed5626637c5c9d4bedaef6f7a6cb4d45212
DIST pbr-5.11.1.tar.gz 127597 BLAKE2B 4ed433f271b4cbed3e7baca66cbeef057d575b7b061507c45a65ba93704edbed7b6f8668e9b9766f03079aaf06dbd6c394960c1c528b1beb992db65d0c3b89e4 SHA512 466dc5ce2622c43451186698f00d405141878449ffe9f7771b0057e8356bf12b426a9bfefff7e5843f1b3f963af3ffc9c4a42fa91a9407b79617abea046ff438
+DIST pbr-6.0.0.tar.gz 123150 BLAKE2B ed41fcf9febc11fe664d3045a8ac01f7a549f770e359b29045508653bffa838d91797c4aec5d5d1eba97907e83fb199f78afa4fd6f0b6be6b93b2e5f781d4425 SHA512 35cb184b02c9bc38e839e652d1f114197b2a82255f824253e156666a07dee1d19823ab4f2fb17b1f4376c775295f533e006cb58136ee978f9989e98a3f782120
EBUILD pbr-5.11.1.ebuild 2145 BLAKE2B eec670420a6e6687ee7e8b5138e4831008ab7e83d76fb56338cf43d1c4c6c369d23f4dd0f7ae2e5c3be1a0a7ceb2f172d320c5fa331251182db430636643abfa SHA512 07c6edf8c2433de2fb9e50e1b4491bc67f18ce6bd37e7652433a3259f3fc9fe295391205933c9b3f7303f3cbcbf728425591583cd3f840a6feb399ba8afa30e3
+EBUILD pbr-6.0.0.ebuild 2056 BLAKE2B e0bd8e99ee83541d85db6f259be4e9ed8dc2fc4b41bd24633aac6f099963b8104ea6d71874bdd462d2e6cbedbe5e8220ee1ebb7c7cfba2f2f82fa9299fe32b73 SHA512 e0320a433f45376729e3d6fcac3c276727afb27ac8deb63a164292db9be04d82fcff25cf497ad281a6227d2ad921c8b249c30a8325e703fc6c46039cd687e2ed
MISC metadata.xml 815 BLAKE2B 439ee90d79572a8653f1ae3b8b5bf0883adb34ceac5257458dba7a2505e25ebba1c5080095139f6521d8fbd57c11ea38cf4049710b584069aea0ebaa7760077a SHA512 3d0618ef6656706acd829be80b2e6a0b0763b5f4128dcd360f28818d42cbc8825ecd04f7f47af5929a3a35fd60a3b9f9816cc37ee30af164c2e5b51764c25afe
diff --git a/dev-python/pbr/pbr-6.0.0.ebuild b/dev-python/pbr/pbr-6.0.0.ebuild
new file mode 100644
index 000000000000..cd958f758db7
--- /dev/null
+++ b/dev-python/pbr/pbr-6.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="
+ https://opendev.org/openstack/pbr/
+ https://github.com/openstack/pbr/
+ https://pypi.org/project/pbr/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
+"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and
+# https://bugs.gentoo.org/show_bug.cgi?id=561038 docutils is needed for sphinx
+# exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848 stestr is run as
+# external tool.
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # TODO: investigate
+ sed -e 's:test_console_script_develop:_&:' \
+ -e 's:test_console_script_install:_&:' \
+ -e 's:test_setup_py_keywords:_&:' \
+ -i pbr/tests/test_core.py || die
+ # network
+ rm pbr/tests/test_wsgi.py || die
+ # installs random packages via pip from the Internet
+ sed -e 's:test_requirement_parsing:_&:' \
+ -e 's:test_pep_517_support:_&:' \
+ -i pbr/tests/test_packaging.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Testing on ${EPYTHON} is not supported at the moment"
+ return
+ fi
+
+ eunittest -b
+}