summaryrefslogtreecommitdiff
path: root/dev-python/pbr/pbr-0.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pbr/pbr-0.8.2-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pbr/pbr-0.8.2-r1.ebuild')
-rw-r--r--dev-python/pbr/pbr-0.8.2-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pbr/pbr-0.8.2-r1.ebuild b/dev-python/pbr/pbr-0.8.2-r1.ebuild
deleted file mode 100644
index 08693bb11aed..000000000000
--- a/dev-python/pbr/pbr-0.8.2-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Injects some useful and sensible default behaviors into setuptools"
-HOMEPAGE="https://github.com/openstack-dev/pbr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
- >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
- )"
-PDEPEND=">dev-python/pip-1.4[${PYTHON_USEDEP}]"
-
-# Requ'd for testsuite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-# This normally actually belongs here.
-python_prepare_all() {
- # This test passes when run within the source and doesn't represent a failure, but rather
- # a gentoo sandbox constraint
- # Rm tests that rely upon the package being already installed and fail
- sed -e s':test_console_script_develop:_&:' \
- -e s':test_console_script_install:_&:' \
- -e s':test_sdist_extra_files:_&:' \
- -e s':test_command_hooks:_&:' \
- -e s':test_sdist_git_extra_files:_&:' \
- -i pbr/tests/test_core.py || die
- sed -e s':test_command_hooks:_&:' \
- -e s':test_global_setup_hooks:_&:' \
- -i pbr/tests/test_hooks.py || die
- einfo "rogue tests disabled"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Note; removed tests pass once package is emerged,
- # it's the suite's design that breaks form, not the tests' intended purpose
- testr init
- testr run || die "Testsuite failed under ${EPYTHON}"
-}