summaryrefslogtreecommitdiff
path: root/dev-python/patsy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/patsy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/patsy')
-rw-r--r--dev-python/patsy/Manifest3
-rw-r--r--dev-python/patsy/metadata.xml16
-rw-r--r--dev-python/patsy/patsy-0.4.1.ebuild46
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/patsy/Manifest b/dev-python/patsy/Manifest
new file mode 100644
index 000000000000..0fc2633276cd
--- /dev/null
+++ b/dev-python/patsy/Manifest
@@ -0,0 +1,3 @@
+DIST patsy-0.4.1.zip 425390 BLAKE2B b8d5696abcf35fcd5e49a7d3efdfb201976efdbe7e845f136dd0cdbfb0972d8372e54b8f4141139cff9ad4df3525c67a10a3c71bc1471991a810e834e0dd0ad9 SHA512 24cf2e6f9a33e6dd795a839eb2b2ac9e0d45cd9c3d5250de17722914ac29436d0518388d0696b75d73236eda3c7819dc4fa24d6d9bc37d5ae035dde2af4510c3
+EBUILD patsy-0.4.1.ebuild 1108 BLAKE2B 75d820414680e71455c9b71c669586d2b7ffcd09d1dabc72b170fd1fc626388b4c9afa63d8c31c146fc3b4e3bdd5535d0afc42a99baf48fb89156088a19fca47 SHA512 6a5424428cd8cc91cb955ebfd5e3c0c2dc27fee6ac76e6de2d98ffb6ac5877d0ceceff287f3a9737e815fdd11771faa155f3b36cd3ec7916a3f74236d52f56ba
+MISC metadata.xml 568 BLAKE2B 198b70af00599da8c516753e5ec88fb4353a966a279e4e40db5b57a7bab57f0ec360ac70ebe4dc14b194b147520b0a8d6d35d2e73003c9c70bbbcc3c830b91aa SHA512 57957dc18e93d9bc8d53d72bf8c9e601856ffb1511943034ff30aa7d93761f8b986e67daadf8dbcd57ef7714ebf3dda13ccd345df294809954c942cb9bdd1310
diff --git a/dev-python/patsy/metadata.xml b/dev-python/patsy/metadata.xml
new file mode 100644
index 000000000000..c4917258dafc
--- /dev/null
+++ b/dev-python/patsy/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ A Python package for describing statistical models and for building
+ design matrices. It is closely inspired by and compatible with the
+ 'formula' mini-language used in R and S.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">patsy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/patsy/patsy-0.4.1.ebuild b/dev-python/patsy/patsy-0.4.1.ebuild
new file mode 100644
index 000000000000..b10300a25936
--- /dev/null
+++ b/dev-python/patsy/patsy-0.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}