summaryrefslogtreecommitdiff
path: root/dev-python/patsy/patsy-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/patsy/patsy-0.5.1.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/patsy/patsy-0.5.1.ebuild')
-rw-r--r--dev-python/patsy/patsy-0.5.1.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-python/patsy/patsy-0.5.1.ebuild b/dev-python/patsy/patsy-0.5.1.ebuild
index 7ae07545ef43..55fef3e05212 100644
--- a/dev-python/patsy/patsy-0.5.1.ebuild
+++ b/dev-python/patsy/patsy-0.5.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -13,33 +13,27 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
+IUSE="doc"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+BDEPEND="
doc? (
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ )"
+
+distutils_enable_tests nose
python_compile_all() {
use doc && emake -C doc html
}
-python_test() {
- cd "${BUILD_DIR}" || die
- nosetests -v || die "Testing failed with ${EPYTHON}"
-}
-
python_install_all() {
use doc && HTML_DOCS=( doc/_build/html/. )
distutils-r1_python_install_all