summaryrefslogtreecommitdiff
path: root/dev-python/patsy/patsy-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/patsy/patsy-0.4.1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/patsy/patsy-0.4.1.ebuild')
-rw-r--r--dev-python/patsy/patsy-0.4.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/patsy/patsy-0.4.1.ebuild b/dev-python/patsy/patsy-0.4.1.ebuild
deleted file mode 100644
index 922367425e19..000000000000
--- a/dev-python/patsy/patsy-0.4.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to describe statistical models and design matrices"
-HOMEPAGE="https://patsy.readthedocs.org/en/latest/index.html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- doc? (
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cd "${BUILD_DIR}" || die
- nosetests -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}