summaryrefslogtreecommitdiff
path: root/dev-python/patiencediff/patiencediff-0.2.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /dev-python/patiencediff/patiencediff-0.2.14.ebuild
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'dev-python/patiencediff/patiencediff-0.2.14.ebuild')
-rw-r--r--dev-python/patiencediff/patiencediff-0.2.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/patiencediff/patiencediff-0.2.14.ebuild b/dev-python/patiencediff/patiencediff-0.2.14.ebuild
new file mode 100644
index 000000000000..85391f492bec
--- /dev/null
+++ b/dev-python/patiencediff/patiencediff-0.2.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the patiencediff algorithm"
+HOMEPAGE="
+ https://github.com/breezy-team/patiencediff/
+ https://pypi.org/project/patiencediff/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}