summaryrefslogtreecommitdiff
path: root/dev-python/pathspec/pathspec-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pathspec/pathspec-0.8.1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pathspec/pathspec-0.8.1.ebuild')
-rw-r--r--dev-python/pathspec/pathspec-0.8.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/pathspec/pathspec-0.8.1.ebuild b/dev-python/pathspec/pathspec-0.8.1.ebuild
new file mode 100644
index 000000000000..7c5bd2c156aa
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.8.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths."
+HOMEPAGE="https://github.com/cpburnz/python-path-specification https://pypi.org/project/pathspec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests setup.py