summaryrefslogtreecommitdiff
path: root/dev-python/pathspec/pathspec-0.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
commit6a84e414622fd99c22318ce656a77bb2a0433fc7 (patch)
tree048f41d4a2a9c373e50bf0906c5508e6f5104fae /dev-python/pathspec/pathspec-0.11.0.ebuild
parenta1b20429e7e2ba1b44414459afd5a2b50788cd9c (diff)
gentoo auto-resync : 25:01:2023 - 14:07:44
Diffstat (limited to 'dev-python/pathspec/pathspec-0.11.0.ebuild')
-rw-r--r--dev-python/pathspec/pathspec-0.11.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pathspec/pathspec-0.11.0.ebuild b/dev-python/pathspec/pathspec-0.11.0.ebuild
new file mode 100644
index 000000000000..7fd0f71c54f8
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths"
+HOMEPAGE="
+ https://github.com/cpburnz/python-pathspec/
+ https://pypi.org/project/pathspec/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests unittest