summaryrefslogtreecommitdiff
path: root/dev-python/pathlib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pathlib2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pathlib2')
-rw-r--r--dev-python/pathlib2/Manifest5
-rw-r--r--dev-python/pathlib2/metadata.xml12
-rw-r--r--dev-python/pathlib2/pathlib2-2.1.0.ebuild25
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.0.ebuild38
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
new file mode 100644
index 000000000000..794f08e2059d
--- /dev/null
+++ b/dev-python/pathlib2/Manifest
@@ -0,0 +1,5 @@
+DIST pathlib2-2.1.0.tar.gz 30390 BLAKE2B e009fa866dcdb2a6f078d746c423484bd90df049d59c89427c631cd63ac11376bb5549f45f0e98da036b15c6674040ffc8844fc08b95abb1d677783dedf9e126 SHA512 5dad54d4bf7a37a2c425afeca030a23d802a8a450186292f3d80aa9ee5c2985701871a0386a2f58e2b05b4bbfd7734a238d0a73625c5839237e4f3984088a8b1
+DIST pathlib2-2.3.0.tar.gz 34291 BLAKE2B ef1768f8a9cc9b28f85ef84c0dfdbfce0b0087c1ffb6718e2b13eb007ea3e0ab0eebe946a1bcc2683fed7db46867f415ad2b52abedcdc87fb67bd45d5998aea5 SHA512 715fbd981d42767862dcaf2cc0fee31b9ec5050915ef7d909d14587609a7a5939e32b39736b586a890e7625443bb163832896fcf138b5c2863c451b71c36a124
+EBUILD pathlib2-2.1.0.ebuild 581 BLAKE2B 62d3e1f8e2705db80933876650fa594a8986cf3b74c78039925ca9dc024ddd979491ae254a7b09c1ed83cce2464fbfeccc16106724254373efffc28987aa7f4a SHA512 e14f2bb06e96e63d9812e31da3a27ce9b9d56f1405515c29df695167e48e7f4122f778688f66a20b8ef15630b5dd4fa7affea9b9946362b7124ded7ff0ae2ce3
+EBUILD pathlib2-2.3.0.ebuild 1060 BLAKE2B 936400ce062dae53fed477ce5f201b60e2bc255bed945a8e3bdb9f56d8a91a4e7fc7a53ba8a391ec9e294bdfd3f22732a05e8fdcb937e693ceffcafd53b264e4 SHA512 7d39226f0942a6e513d7053ce397b4e67e73f82621e356a83ca0234906bd93ca82e058ba4d72acdb8abb1b12db29a97ccecf47eda96e8d942ec9e9cd1dfc2fe2
+MISC metadata.xml 371 BLAKE2B e2a18977882b53d7e6588147a17a9fe2c2a1b0850946b15036941b908ece241cace91e66373d5edaa4ac2ba46935413b223ea78cb6ca01b758673ef719b76966 SHA512 dce5315fa4bc25047346fbf06a9f2da5828475bf0b36a1dcdd6ea9917f29ed4bbefc22aba699a43d7b3c5f771939bd81b3da20df54537b22aa4811a19ab62a6e
diff --git a/dev-python/pathlib2/metadata.xml b/dev-python/pathlib2/metadata.xml
new file mode 100644
index 000000000000..c63f13ac24ca
--- /dev/null
+++ b/dev-python/pathlib2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pathlib2</remote-id>
+ <remote-id type="github">mcmtroffaes/pathlib2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pathlib2/pathlib2-2.1.0.ebuild b/dev-python/pathlib2/pathlib2-2.1.0.ebuild
new file mode 100644
index 000000000000..22c3255434e7
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/p/pathlib2/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test_pathlib2.py || die
+}
diff --git a/dev-python/pathlib2/pathlib2-2.3.0.ebuild b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
new file mode 100644
index 000000000000..8196d59d3458
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/p/pathlib2/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 python3_4 )
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
+
+python_prepare_all() {
+ # stop using private Python API
+ # https://github.com/mcmtroffaes/pathlib2/issues/39
+ sed -i -e 's/support\.android_not_root/False/' test*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" test_pathlib2.py -v || die
+ "${EPYTHON}" test_pathlib2_with_py2_unicode_literals.py -v || die
+}