summaryrefslogtreecommitdiff
path: root/dev-python/pathlib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/pathlib2
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/pathlib2')
-rw-r--r--dev-python/pathlib2/Manifest2
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.6.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
index a2c584e88614..612bef259923 100644
--- a/dev-python/pathlib2/Manifest
+++ b/dev-python/pathlib2/Manifest
@@ -1,3 +1,5 @@
DIST pathlib2-2.3.5.tar.gz 34393 BLAKE2B 7e03214a53f1ebf7718d04f653e24ffa4b06070b0ae21583d98ea0ce956c5aced5ea63bf6062d8e8d979bef4c82137cd2d2d5d6121dc3dda0ae1f713c1868d36 SHA512 3f0f212bf5208d0965ac02a590bef6ac0ec5e3b702828c06c3c9d37119b3db422cc7873de614fdc37ebfb3f52239a6517008d9672a176ca15d03fe13baeeddc8
+DIST pathlib2-2.3.6.tar.gz 38435 BLAKE2B 07a6db61feb56c439e0c4c97d96f87714090628d3971341b64ed253cf9b363b7a3695a665a3def5c2b950cd3dc2ba316ef3dcfaf48f25726fce34afedccdafac SHA512 ed41792338d5808cdd068f6c04021b2918e5376fc6297f163712dec6b00a1f96f7905eeea0a601c333d253e0f1663a0472d842b0d920d680992045bbc36db970
EBUILD pathlib2-2.3.5-r1.ebuild 878 BLAKE2B 55031cd932b49489427c98dab76661ea9d4709845b0cbdc7e65d95e0568428b6e10fc26c67a679248bc55fd3321ea1862bb61573cc883254be3746eb0897568c SHA512 6e7716fd74c4dda31c8206ecdaa4848812f556bfdd5842d27bc738e805f58c8517f827a4cb0d498c49f26fd3ef2e42525269095eeb92dbc936826d49cef4f953
+EBUILD pathlib2-2.3.6.ebuild 752 BLAKE2B 6910945f64137611fce99746fd424611bbc532d56fd822a1aa92bbd7f052b1f4c202002b55b3da78c5743964fdd8b260507bbf2149178992723bbbddd022d872 SHA512 2a5950f56d2b0be44ee1c6a15f76ef9338cba289701ecb872a63d4f984a8cbd041509ccef573b4a9f6d71c6517fef9de39c70b19a37861e2ae8df0436cb263ec
MISC metadata.xml 463 BLAKE2B 1ade185c5ac11844715bf67d798fa910d2fde357f1953688c28d94477e2b5a68613178c8a3eaba42ae8285a49cc94b37ad5a559d80771f763ed06a2dc952747e SHA512 45a09691f2b57c336a752f4a881aa1d91173102d6b89a33e7583e99d13c18610fd29f248287cda00d31bbd265a68f11b60e911644f6689c76c1704fa2c901100
diff --git a/dev-python/pathlib2/pathlib2-2.3.6.ebuild b/dev-python/pathlib2/pathlib2-2.3.6.ebuild
new file mode 100644
index 000000000000..ac123963984c
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v ||
+ die "tests failed with ${EPYTHON}"
+}