summaryrefslogtreecommitdiff
path: root/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild b/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild
new file mode 100644
index 000000000000..36f159e9e542
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2)
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v || \
+ die "tests failed with ${EPYTHON}"
+}