summaryrefslogtreecommitdiff
path: root/dev-python/path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 11:04:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 11:04:31 +0000
commit5944ce177026c93b7dab690db9d970567ddbf75f (patch)
tree98cde802bce7341b8039a2189a44a6e85f5a426b /dev-python/path
parentd0835364e1877539c2b8ce70c1941ebfedd2a91b (diff)
gentoo auto-resync : 05:12:2023 - 11:04:31
Diffstat (limited to 'dev-python/path')
-rw-r--r--dev-python/path/Manifest2
-rw-r--r--dev-python/path/path-16.9.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 4d134f32eb21..94c528875a78 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,3 +1,5 @@
DIST path-16.7.1.tar.gz 48974 BLAKE2B a03eebbb391cf17033adce4d6b258217546e3b7494200a8ea97f756512177f1c7d7ea8155420e167cefe79b566a4240eec98d17b160478f9cb06d3fd839c28f2 SHA512 7d660373046845a5882a316051c350558527d6d8a5cd11735d38214f986c8e096f72b45f87cfec41bf6171e7845287a42e6e45535f87a01b46670eccd4013dbf
+DIST path-16.9.0.tar.gz 48850 BLAKE2B 0c5edc6538cb22543dd810a535840a235b66c51415284f00338bd1e84e63847d09235e55dd3d40a71f3b02f54d18cbbf4fa1e5a0356798cee3383666a26a441c SHA512 2d4c8e3923bc712c7901328a0406ce05c6c157664dfacb5a563a1b214ce561215398b31494865c99a77ed09c3ef63bb04a36d57a60e7c0e3dea05b1dacfdecf7
EBUILD path-16.7.1.ebuild 800 BLAKE2B 6e811206e2db786e31a9d358d9560b4695e6b2a0e6b5abdde043a32da5ac5a70a951a35038fd52de2506c70fd4a77c46b9c817f63f5e25fed25260df81363f68 SHA512 5602ad85e8f7d1759d7f7200fab7d5c4848880b9072b43d51628348d5798a8e3266cf9c62515391f6c963a95842f120f951696d200aaaca66e06504bc84d6079
+EBUILD path-16.9.0.ebuild 854 BLAKE2B 810ed2e822c935424c26284086cd7680bc1d380f0280c78066c37ff0b2f60549642c4c51244cd2dcbca89d0e58fcd1aa0d0844a5d80588be2b39a310a191778a SHA512 1f5bd95a315f8d48f341ce921583c346d3c08ac97ef262142ea53bb9c3bce589c7a26459808e3b97d8ef381a2a634e5ac07bc49ec9256e7a08b7fa557c10bf4b
MISC metadata.xml 383 BLAKE2B 30f12776bf4f9c1995774d7dc68cd8d9a85b74d514e8239ba76af336e6b08979e496ddaffce999bf0a3557f88ced148335024628b61f765b5bd08bf90b453c5a SHA512 aaceff1caa2714c0b8b3f7373c8721358e63833cfac824e3feda8a34fd1d6a961a27805c012a1125cad1f76d8bf7b1a92d7719480d90b344e5b4d0260ccf0547
diff --git a/dev-python/path/path-16.9.0.ebuild b/dev-python/path/path-16.9.0.ebuild
new file mode 100644
index 000000000000..52a7318fd514
--- /dev/null
+++ b/dev-python/path/path-16.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)