summaryrefslogtreecommitdiff
path: root/dev-python/path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
commit2ad011cd42b40aebf90105be4521fb1727266d1d (patch)
treed9dc4f7c1665a6ba336ba8a9fa773f1292895b76 /dev-python/path
parente0dcb1c4ea48292b379fadd53f55f1df42cf7eab (diff)
gentoo auto-resync : 26:09:2022 - 15:08:08
Diffstat (limited to 'dev-python/path')
-rw-r--r--dev-python/path/Manifest5
-rw-r--r--dev-python/path/metadata.xml13
-rw-r--r--dev-python/path/path-16.4.0.ebuild38
-rw-r--r--dev-python/path/path-16.5.0.ebuild42
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
new file mode 100644
index 000000000000..482ce1bf85c9
--- /dev/null
+++ b/dev-python/path/Manifest
@@ -0,0 +1,5 @@
+DIST path-16.4.0.tar.gz 48289 BLAKE2B 5ae3272ecc92689c18ffc612b8b11923225dcface88fa47dc4f42b0dc960034fa6a3c856a9521ed83c9507616577efc3d1c0a5119b0c5605ea6f6b758cfe6d2b SHA512 bb78119f929fe3b160646b06db8911e737060695ae89c28bcce84835213dfbaa12a34300b540be6b51e9462c5b378b235e1e72536524750ec910255399c513d3
+DIST path-16.5.0.gh.tar.gz 44286 BLAKE2B 1d96b0003c562044c1c2ba5eba7a525d5503bd9a58ec1f9611d74e9d52581f646447d3d754809b49b4418c18de9fbfd5de34077fe9edb1c4b3d3fd49f9c2af19 SHA512 0b9b306b2b5cce1e51d65a7555e54770e19a3d4796dbaf2d617bbe8282c771e3d7975112e443462e9b43bafc533d6dc61bedb8608b0d93cc0d1febec995d1780
+EBUILD path-16.4.0.ebuild 939 BLAKE2B 90548c033f04219bae6890a200a912b51c64af262a56102be69e5cfe0c2b5927533223ab5009e3500804a5a6d1870762d2ba65282a5b33c27f1f008cb6a7fa27 SHA512 ab9640a54d97adcd7b44355aa8bef25b3d9b903c7b71c63a98c8b7b00f92a16d4ff2fb1383fa41e52a29c0f3a5dddf6354b0d25bb494db9cec33970f8ddd152d
+EBUILD path-16.5.0.ebuild 920 BLAKE2B bbfc51ae3e83c511322a9123e2ab974970c697d259c1c05f3a8393548b367dfc78fbd43f63edda4942d62e6ce07d315281f353676e796cdf1c1e5f7c61a85593 SHA512 fcdc1d9f63008a8437d2b6977f426a082cd242918faf471897979f006586f65dd4bbd4741c46db74bef980cbcbd8780a27282850148d522ee18facbcb6c17289
+MISC metadata.xml 383 BLAKE2B 30f12776bf4f9c1995774d7dc68cd8d9a85b74d514e8239ba76af336e6b08979e496ddaffce999bf0a3557f88ced148335024628b61f765b5bd08bf90b453c5a SHA512 aaceff1caa2714c0b8b3f7373c8721358e63833cfac824e3feda8a34fd1d6a961a27805c012a1125cad1f76d8bf7b1a92d7719480d90b344e5b4d0260ccf0547
diff --git a/dev-python/path/metadata.xml b/dev-python/path/metadata.xml
new file mode 100644
index 000000000000..a0ad5ac4421d
--- /dev/null
+++ b/dev-python/path/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">path</remote-id>
+ <remote-id type="github">jaraco/path</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/path/path-16.4.0.ebuild b/dev-python/path/path-16.4.0.ebuild
new file mode 100644
index 000000000000..6338c832adad
--- /dev/null
+++ b/dev-python/path/path-16.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P="path-${PV}"
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)
diff --git a/dev-python/path/path-16.5.0.ebuild b/dev-python/path/path-16.5.0.ebuild
new file mode 100644
index 000000000000..ecd7e2ae4fa3
--- /dev/null
+++ b/dev-python/path/path-16.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+SRC_URI="
+ https://github.com/jaraco/path/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}