summaryrefslogtreecommitdiff
path: root/dev-python/path/path-16.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
commit34f71cb8541190212fa250ceb3dafb53f383beea (patch)
tree75894a0bd212c9a6464b37d48f418fcb5cc3ff82 /dev-python/path/path-16.12.1.ebuild
parent18bf6672cbde96e8498ce4bfc974af9bb4f95613 (diff)
gentoo auto-resync : 04:04:2024 - 20:14:38
Diffstat (limited to 'dev-python/path/path-16.12.1.ebuild')
-rw-r--r--dev-python/path/path-16.12.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/path/path-16.12.1.ebuild b/dev-python/path/path-16.12.1.ebuild
new file mode 100644
index 000000000000..5346cd3c6d67
--- /dev/null
+++ b/dev-python/path/path-16.12.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)