summaryrefslogtreecommitdiff
path: root/dev-python/path-py/path-py-16.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/path-py/path-py-16.2.0.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/path-py/path-py-16.2.0.ebuild')
-rw-r--r--dev-python/path-py/path-py-16.2.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/path-py/path-py-16.2.0.ebuild b/dev-python/path-py/path-py-16.2.0.ebuild
deleted file mode 100644
index 161aeaf60c7a..000000000000
--- a/dev-python/path-py/path-py-16.2.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_P="path-${PV}"
-DESCRIPTION="A module wrapper for os.path"
-HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
-SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- !<dev-python/pytest-shutil-1.7.0-r1
- !<dev-python/pytest-virtualenv-1.7.0-r1"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # unreliable, not really meaningful for end users
- test_path.py::TestPerformance
- )
-
- epytest ${deselect[@]/#/--deselect }
-}