summaryrefslogtreecommitdiff
path: root/dev-python/paste
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /dev-python/paste
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-2.0.3.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 0d5e752c9b2f..59dd2ea50222 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1,5 +1,4 @@
AUX paste-2.0.3-unbundle-tempita.patch 1260 BLAKE2B eee8a9ede07730cc6af7de910a0298bfac23f6d2b31467101375720782920d878716bf91a031ba651e00a61f3a7201708e94ecd8b78f1bd6a52c50ef2826f8d5 SHA512 f21894596c81d984bd7820876e7dfc614728beba107294fecbab084ae1e023428d4d86bde31e428c2f0aa78647636d19f476129ff319dd2c90052218cf428c98
DIST Paste-2.0.3.tar.gz 643935 BLAKE2B 140f88cbab40728713a052e5aca0c7f14336d526a2c7bcd6a279fcdd13b14ed83938f69997182b43d2a83a76f51586c3b9132428f0f9c9e9ba08b6ff820827b9 SHA512 174b06d77bc6e1d4079e8de7df40412ffda098364efd4e3f915f858be1188c8a6fb546fe4ab981ccc067ec77b7171083b2469e7db6fc3b777d5a24151c928362
EBUILD paste-2.0.3-r1.ebuild 1872 BLAKE2B edb9ed5ec02748f7674de1fcdcc09318e908860118b82dd332ca187ea2f1daee9ce3cbdc8102974737b6d5ccab7f2e84eb68459e9b08d0e96f2e156410bcb362 SHA512 cdc63f9e497b9434e7b0d62adaaf92b3ad8da6a93acbef85f858e4e1383e81b5c0101261af7dba7902091014c7104d0e973783dcfbbaec72aa2f06c2af229fd3
-EBUILD paste-2.0.3.ebuild 1783 BLAKE2B 2845911ee345a8aed64e796b6e8537c96f75e6441f98d97b0376060e1e6aa87d926752da8fe1c96cdd1d52fff0866609647bcb3f5275793b60432d3c9ed96632 SHA512 8beb71282d2c3ea118fd86e380a98dd85f8a50aa8d947b742dfcbfd891a669cdfdba56490c92eb02a4343cb282da37df9d0bffe4f85c3714d5ab0810119d02a2
MISC metadata.xml 778 BLAKE2B 74d5474ab918861e65f330eff278a319f8b197c6f95e65c862e55bd19d84534c447e348df82ddc68558dd089f8ac81785c16de38e3fdc70f706d4e5b870243fc SHA512 86b244a3dd365e74dfc12dfc283809840352cbe210b34c34ffda1929db29362d1e02b246920d8461cde70b087020d15cecd3ec5cfe0f168fb69fa45cdb66015a
diff --git a/dev-python/paste/paste-2.0.3.ebuild b/dev-python/paste/paste-2.0.3.ebuild
deleted file mode 100644
index a41dcdc1d171..000000000000
--- a/dev-python/paste/paste-2.0.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-MY_PN="Paste"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="http://pythonpaste.org https://pypi.python.org/pypi/Paste"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="doc flup openid"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/tempita-0.5.2_pre20130828[${PYTHON_USEDEP}]
- flup? ( dev-python/flup[$(python_gen_usedep 'python2*')] )
- openid? ( dev-python/python-openid[$(python_gen_usedep 'python2*')] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Disable failing tests.
- rm -f tests/test_cgiapp.py || die
- sed \
- -e "s/test_find_file/_&/" \
- -e "s/test_deep/_&/" \
- -e "s/test_static_parser/_&/" \
- -i tests/test_urlparser.py || die "sed failed"
-
- # Remove a test that runs against the paste website.
- rm -f tests/test_proxy.py || die
-
- local PATCHES=(
- "${FILESDIR}"/${P}-unbundle-tempita.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile egg_info --egg-base "${BUILD_DIR}/lib"
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests -P -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install egg_info --egg-base "${BUILD_DIR}/lib"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}