summaryrefslogtreecommitdiff
path: root/dev-python/paste/paste-3.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
commit68a32bc9fda17e8a546c0bba9d113c4c4659f6bb (patch)
treee043bb32648a3c75289450c0f4252aaabc1d4593 /dev-python/paste/paste-3.7.1.ebuild
parent74a32c3ccafc7895a037d2b0cf73fc726286ec2e (diff)
gentoo auto-resync : 06:04:2024 - 18:30:38
Diffstat (limited to 'dev-python/paste/paste-3.7.1.ebuild')
-rw-r--r--dev-python/paste/paste-3.7.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/paste/paste-3.7.1.ebuild b/dev-python/paste/paste-3.7.1.ebuild
deleted file mode 100644
index aef584aa32f4..000000000000
--- a/dev-python/paste/paste-3.7.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="
- https://pythonpaste.readthedocs.io/en/latest/
- https://github.com/cdent/paste/
- https://pypi.org/project/Paste/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- !dev-python/namespace-paste
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- tests/test_proxy.py
- )
-
- [[ ${EPYTHON} == python3.1[12] ]] && EPYTEST_DESELECT+=(
- # fails due to cgi deprecation warning
- tests/test_cgiapp.py::test_form
- )
-
- epytest
-}