summaryrefslogtreecommitdiff
path: root/dev-python/passlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
commit6243676c91946098c06d42bc87b5eb99aac40bf0 (patch)
treee6de308ba22148b4898b67b049c7f017ece8fea2 /dev-python/passlib
parentb987a550f067c3da93b0664cf1fdc8a624c0aa38 (diff)
gentoo auto-resync : 25:04:2024 - 23:59:45
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/Manifest3
-rw-r--r--dev-python/passlib/files/passlib-1.7.4-bcrypt-4.1.patch13
-rw-r--r--dev-python/passlib/passlib-1.7.4-r3.ebuild (renamed from dev-python/passlib/passlib-1.7.4-r2.ebuild)12
3 files changed, 25 insertions, 3 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index 684719a208c7..20d5af684ad3 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1,3 +1,4 @@
+AUX passlib-1.7.4-bcrypt-4.1.patch 540 BLAKE2B 04c450774f051d42aa6ef16c911583f68e3df8e69a2a98b25f54bc622f13c455f3e3696e2ccdf2f3810e5ec0a1d978ccbb3aef8eb51f768cc01cd8af81edaaaa SHA512 db57eae2431f31fb5f89e25cf4e0344b4a40fe034b1a88fe4d41af51fa20f9c9fb01dbd626bf7671d67774e0e5efd3ee94a8b5061bde1a3bde737cef3e8259e2
DIST passlib-1.7.4.tar.gz 689844 BLAKE2B 38f616105ba70cf93cf36383c73f2a4da7bf66ced2844effffe74d9f7c29ee0aece5652974dd1414f16e32fbe6957e2e921cf01bc59daa70195a6d50a4a3bf2f SHA512 350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530
-EBUILD passlib-1.7.4-r2.ebuild 1319 BLAKE2B 95f02e9a83ea8d13027a899e7850a26951ccd91413cb2c6fb9435986c86b18cae625d2c9be1a1017cd9b8d034634dffc7e0642d7348a6fcf65ea13408a2e9957 SHA512 58076fec77f5d2d302dc09b401cb7ddebbb166ffeca0f3a321fb5b86a4623805ee6e25fdaf7c25c34f204e61a3f3cef9fe7663febdbe587ef8712602a932a3a4
+EBUILD passlib-1.7.4-r3.ebuild 1548 BLAKE2B 2cfba596ea958c3a7e4b24454f9e45da14266fa886169eabfd6b40c4181c9df5be502299cdc0881cde3dcf1adca28dfd9c5dc72dbf804710075d8cdb40254ee1 SHA512 5c7fe5742ffb45337d24b38e83a9e152c97356385bf713330ce21a3e87513dc7c2ca87e5bdbc9707b062645dbecb2128d2628077b2d0da80d54fcdef4b51702e
MISC metadata.xml 618 BLAKE2B ae1d81ff9a45b639031fb9e143899a866c74fd20a5bba55d9defac47c7fd51e491822b272983d19546f30d636f930f3582441318d338e66f25d30e97160f74cb SHA512 45a87efb8f21d2b1e578f5bebfc4a820589aa401ffc623ee5ea81888700ce59cb47c769993ebc2165dd5fd6e3051c882c8dd60ee068a6113390b16ba424325f6
diff --git a/dev-python/passlib/files/passlib-1.7.4-bcrypt-4.1.patch b/dev-python/passlib/files/passlib-1.7.4-bcrypt-4.1.patch
new file mode 100644
index 000000000000..706ff73f3b5f
--- /dev/null
+++ b/dev-python/passlib/files/passlib-1.7.4-bcrypt-4.1.patch
@@ -0,0 +1,13 @@
+diff --git a/passlib/handlers/bcrypt.py b/passlib/handlers/bcrypt.py
+index b83b110..42dd019 100644
+--- a/passlib/handlers/bcrypt.py
++++ b/passlib/handlers/bcrypt.py
+@@ -617,7 +617,7 @@ class _BcryptBackend(_BcryptCommon):
+ except ImportError: # pragma: no cover
+ return False
+ try:
+- version = _bcrypt.__about__.__version__
++ version = _bcrypt.__version__
+ except:
+ log.warning("(trapped) error reading bcrypt version", exc_info=True)
+ version = '<unknown>'
diff --git a/dev-python/passlib/passlib-1.7.4-r2.ebuild b/dev-python/passlib/passlib-1.7.4-r3.ebuild
index 708ef7f23b53..981e5c61a393 100644
--- a/dev-python/passlib/passlib-1.7.4-r2.ebuild
+++ b/dev-python/passlib/passlib-1.7.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,8 +15,8 @@ HOMEPAGE="
"
LICENSE="BSD-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
IUSE="doc test-rust"
BDEPEND="
@@ -30,6 +30,14 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # fix compatibility with >=dev-python/bcrypt-4.1
+ # https://foss.heptapod.net/python-libs/passlib/-/issues/190
+ sed -i -e '/bcrypt/s:__about__\.::' passlib/handlers/bcrypt.py || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
local EPYTEST_DESELECT=(
# broken all the time by new django releases