summaryrefslogtreecommitdiff
path: root/dev-python/passlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /dev-python/passlib
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/Manifest1
-rw-r--r--dev-python/passlib/passlib-1.7.4-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index 3f5c1eaf3d62..54fcf5620958 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1,3 +1,4 @@
DIST passlib-1.7.4.tar.gz 689844 BLAKE2B 38f616105ba70cf93cf36383c73f2a4da7bf66ced2844effffe74d9f7c29ee0aece5652974dd1414f16e32fbe6957e2e921cf01bc59daa70195a6d50a4a3bf2f SHA512 350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530
+EBUILD passlib-1.7.4-r1.ebuild 1045 BLAKE2B cb1c022ecb79eb5d785ccab7887b21be57cc32e6af2b1b89e03355a44cedd0312ddc34dc64bb81ade4fa3a3a9846cb93724b8d58e2d53ef3097dd6ca5b27c4ce SHA512 fa3608b3626de20efc215226b51754c224343457fe427dcaf91d81c07f316d15869bf5b239726829276bbd02df6ebfb93166d06e9d08832015be3b968a5679cf
EBUILD passlib-1.7.4.ebuild 959 BLAKE2B 139467429cce1ccb944a5fe8b6f5ea483bd6b8677823e7c51590dd6de8d2c7959ce769af84c3eae650535e69601ad3a933ca0de3a911ab5d28a777c37d838367 SHA512 26a367e61736bfd755f2a7cde3e3dc1cc121a11a9a4d912d8a675f21a89ae2f875f4a89e338b5dd7a9a27c2707fdfdb40fe5741f3859d92e1fbf42bd0d778b25
MISC metadata.xml 821 BLAKE2B b59269c8e94ac7bbf7fec98974e2cb2b7211842b35ec0a447cdb8a988d5b42cfe7f47572e7d1a3078be206bb01d79a3e45f24ab7fb052998da8db2015129b51a SHA512 3889ce6c307f18408c5b0b6b0590ad61703a04bc7f7d31596977b9d32a93ff3a81389ae354e67ca4a59a53a2347e316c0fbfb91c15df5f41a15c200b13c68fb3
diff --git a/dev-python/passlib/passlib-1.7.4-r1.ebuild b/dev-python/passlib/passlib-1.7.4-r1.ebuild
new file mode 100644
index 000000000000..f4c350e93f5a
--- /dev/null
+++ b/dev-python/passlib/passlib-1.7.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Password hashing framework supporting over 20 schemes"
+HOMEPAGE="https://foss.heptapod.net/python-libs/passlib/wikis/home"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/scrypt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
+}
+
+pkg_postinst() {
+ optfeature "Argon2 support" dev-python/argon2-cffi
+ optfeature "bcrypt support" dev-python/bcrypt
+ optfeature "scrypt support" dev-python/scrypt
+ optfeature "Time-based One-Time Password (TOTP) support" dev-python/cryptography
+}