summaryrefslogtreecommitdiff
path: root/dev-python/passlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/passlib
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/Manifest2
-rw-r--r--dev-python/passlib/passlib-1.7.4-r2.ebuild (renamed from dev-python/passlib/passlib-1.7.4-r1.ebuild)22
2 files changed, 19 insertions, 5 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index 8b2dbc5cd2ea..db79caf61f0e 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1,3 +1,3 @@
DIST passlib-1.7.4.tar.gz 689844 BLAKE2B 38f616105ba70cf93cf36383c73f2a4da7bf66ced2844effffe74d9f7c29ee0aece5652974dd1414f16e32fbe6957e2e921cf01bc59daa70195a6d50a4a3bf2f SHA512 350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530
-EBUILD passlib-1.7.4-r1.ebuild 1089 BLAKE2B 122c3a0498fa6887733d97d89a84b8bfd82da215f1096b23f232d6bb3e088ae48b61e20bf1a42b4818a1ec110ce89b6e5248b714178300893a6f4048fd90a1d8 SHA512 4e2dd4d3918678b8455c1f1c4984d8178880e1339409c9e48ed68ee7548aa33d88cc2179418afe5040541002709dacc869dd98dd263a440df69b094f7ca0541e
+EBUILD passlib-1.7.4-r2.ebuild 1372 BLAKE2B f7302b1927e4605d29ff5711917b34adad611c29f7f62589258757643cec443000c442ab6c1890acdc25d994489a4613eac59fa32f1faa8f4625830af03514bd SHA512 5e42070795a90fc68c5a5ee214188b9e7c446deab53482b048273d2b324d3226ac0d14f41a4bd70cada30050fe1aee5abdd78076886f2cd9d6b2e9fe08539823
MISC metadata.xml 618 BLAKE2B ae1d81ff9a45b639031fb9e143899a866c74fd20a5bba55d9defac47c7fd51e491822b272983d19546f30d636f930f3582441318d338e66f25d30e97160f74cb SHA512 45a87efb8f21d2b1e578f5bebfc4a820589aa401ffc623ee5ea81888700ce59cb47c769993ebc2165dd5fd6e3051c882c8dd60ee068a6113390b16ba424325f6
diff --git a/dev-python/passlib/passlib-1.7.4-r1.ebuild b/dev-python/passlib/passlib-1.7.4-r2.ebuild
index b8449306ebb0..d31eb973137f 100644
--- a/dev-python/passlib/passlib-1.7.4-r1.ebuild
+++ b/dev-python/passlib/passlib-1.7.4-r2.ebuild
@@ -3,13 +3,17 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1 optfeature
DESCRIPTION="Password hashing framework supporting over 20 schemes"
-HOMEPAGE="https://foss.heptapod.net/python-libs/passlib/wikis/home"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://foss.heptapod.net/python-libs/passlib/-/wikis/home
+ https://pypi.org/project/passlib/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
@@ -25,7 +29,17 @@ BDEPEND="
) ) )
)"
-distutils_enable_tests nose
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken all the time by new django releases
+ passlib/tests/test_ext_django.py
+ )
+
+ # skip fuzzing tests, they are very slow
+ epytest -k "not fuzz_input"
+}
python_install_all() {
distutils-r1_python_install_all