summaryrefslogtreecommitdiff
path: root/dev-python/passlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-python/passlib
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/Manifest2
-rw-r--r--dev-python/passlib/passlib-1.7.4-r3.ebuild12
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index 308b58bb2797..46840be826c4 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1,3 +1,3 @@
DIST passlib-1.7.4.tar.gz 689844 BLAKE2B 38f616105ba70cf93cf36383c73f2a4da7bf66ced2844effffe74d9f7c29ee0aece5652974dd1414f16e32fbe6957e2e921cf01bc59daa70195a6d50a4a3bf2f SHA512 350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530
-EBUILD passlib-1.7.4-r3.ebuild 1548 BLAKE2B 2cfba596ea958c3a7e4b24454f9e45da14266fa886169eabfd6b40c4181c9df5be502299cdc0881cde3dcf1adca28dfd9c5dc72dbf804710075d8cdb40254ee1 SHA512 5c7fe5742ffb45337d24b38e83a9e152c97356385bf713330ce21a3e87513dc7c2ca87e5bdbc9707b062645dbecb2128d2628077b2d0da80d54fcdef4b51702e
+EBUILD passlib-1.7.4-r3.ebuild 1792 BLAKE2B 5e8dd137082321c0deb3e3f16b2f28236005c345c3fdd7b84cf589c7e2a8806fa3654dc18c6ae81e03411e98dfb9797bd4f9e02465c38fd9d48f464fb1120068 SHA512 11ee15ae4fa0f878e1d2397a49eb48ccbfeb68c8f019da0950093c9757ccef02e1633975378352e43adc4bf66480c75fd377fb31ecca72bde0e477e046ff4889
MISC metadata.xml 618 BLAKE2B ae1d81ff9a45b639031fb9e143899a866c74fd20a5bba55d9defac47c7fd51e491822b272983d19546f30d636f930f3582441318d338e66f25d30e97160f74cb SHA512 45a87efb8f21d2b1e578f5bebfc4a820589aa401ffc623ee5ea81888700ce59cb47c769993ebc2165dd5fd6e3051c882c8dd60ee068a6113390b16ba424325f6
diff --git a/dev-python/passlib/passlib-1.7.4-r3.ebuild b/dev-python/passlib/passlib-1.7.4-r3.ebuild
index 981e5c61a393..19f9172fdcb4 100644
--- a/dev-python/passlib/passlib-1.7.4-r3.ebuild
+++ b/dev-python/passlib/passlib-1.7.4-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 optfeature pypi
@@ -44,6 +44,16 @@ python_test() {
passlib/tests/test_ext_django.py
)
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # crypt module has been removed, so the platform backend
+ # does not work anymore
+ passlib/tests/test_handlers.py::{des,md5,sha256,sha512}_crypt_os_crypt_test
+ )
+ ;;
+ esac
+
# skip fuzzing tests, they are very slow
epytest -k "not fuzz_input"
}