summaryrefslogtreecommitdiff
path: root/dev-python/passlib/passlib-1.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/passlib/passlib-1.7.2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/passlib/passlib-1.7.2.ebuild')
-rw-r--r--dev-python/passlib/passlib-1.7.2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/passlib/passlib-1.7.2.ebuild b/dev-python/passlib/passlib-1.7.2.ebuild
deleted file mode 100644
index b54d3c320eb5..000000000000
--- a/dev-python/passlib/passlib-1.7.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Password hashing framework supporting over 20 schemes"
-HOMEPAGE="https://foss.heptapod.net/python-libs/passlib/wikis/home"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-SLOT="0"
-IUSE="+bcrypt doc +scrypt +totp"
-
-RDEPEND="bcrypt? ( dev-python/bcrypt[${PYTHON_USEDEP}] )
- totp? ( dev-python/cryptography[${PYTHON_USEDEP}] )
- scrypt? ( dev-python/scrypt[${PYTHON_USEDEP}] )"
-BDEPEND="
- test? (
- dev-python/bcrypt[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/scrypt[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/passlib-1.7.2-pypy3.patch"
- "${FILESDIR}/passlib-1.7.2-py39.patch"
-)
-
-distutils_enable_tests nose
-
-python_install_all() {
- distutils-r1_python_install_all
- use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
-}