summaryrefslogtreecommitdiff
path: root/dev-python/partd/partd-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-26 18:57:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-26 18:57:55 +0000
commitdd8cf418a044466cd5a1239059d5d21744f73f14 (patch)
tree0d4b5a88a46cdc31e1f7f8f302ac8114e3f94a9d /dev-python/partd/partd-1.4.1.ebuild
parent6887f21af5af228689c7587c4adf37baa07d563f (diff)
gentoo auto-resync : 26:01:2024 - 18:57:55
Diffstat (limited to 'dev-python/partd/partd-1.4.1.ebuild')
-rw-r--r--dev-python/partd/partd-1.4.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/partd/partd-1.4.1.ebuild b/dev-python/partd/partd-1.4.1.ebuild
index c270ee99175d..a9e21511beef 100644
--- a/dev-python/partd/partd-1.4.1.ebuild
+++ b/dev-python/partd/partd-1.4.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -23,6 +23,7 @@ RDEPEND="
dev-python/toolz[${PYTHON_USEDEP}]
"
BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
test? (
dev-python/blosc[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -33,3 +34,9 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+src_prepare() {
+ # remove outdated version
+ rm versioneer.py || die
+ distutils-r1_src_prepare
+}