summaryrefslogtreecommitdiff
path: root/dev-python/parso
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /dev-python/parso
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest2
-rw-r--r--dev-python/parso/parso-0.5.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 285e51682270..76b60e22c9b2 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,5 +1,7 @@
DIST parso-0.3.1.tar.gz 375226 BLAKE2B 71481f5f382f14e5f2c7826f8eb50a1c35f8c280f14c8bf52bcf44f77aa9872cddce7d7fb7b0a586ab7cda547e43bbce11812077ae84129c418a9f0bb3c5b856 SHA512 f83e316a41e21d3132d9ee8a45f9042962c01a2b906e8791046112b9ed938d378b0dc28c4ae05ce03a8c2d19563a49cba9a9a230654345ff62e87cc763536ddb
DIST parso-0.5.0.tar.gz 386652 BLAKE2B f12e34aa9b93a1d3eedca96588148ac1e9ecb3a6af3910627d251e2281df285ce8768c11bf3cac35f8a977f0dac2f7a906fb20171db35fae2bec1c60cd0d7dc6 SHA512 cd2a38e538faf4faf3f1828f4e69dfe685ef1fd3e120326ca5260f0edbc23952e51ffd8370a2bb2de513a90ecde76e6ea2fe76d84d3ab4115c7817e3af08e701
+DIST parso-0.5.1.tar.gz 388060 BLAKE2B 429ab40501d38e982cf77e0dbbfa4d8677dd1e2400945436b8eced608a41015b7028f586cf9af6057e441765f0a1db519a642ceadaba14620a92f452ce709871 SHA512 a04ef9bbe156bc28ac9fa64d091d3f1dcc9cf4b15a3c109cd33de1c4d34d0bf741016b88b6c12d456e953253942b7d522e0b793c9a00e9fb06de27ab0667c7fc
EBUILD parso-0.3.1.ebuild 881 BLAKE2B e1da487c3c25e9cbea3e9c54bd70a9499d10ea80f11be51e21dffe3e97e9c8d0a26a4318cdb9e795182aa5cc7f8b76ca97579c91ac7a43fcb19e4d4eabf87c81 SHA512 07919403e2eb42df62695ae253d53ea9644804c7ea1fe8bceafd755d832699adbcb6332b3e455388cb1e34faafb512e17427349e702be0a8dbfc6160149c44a2
EBUILD parso-0.5.0.ebuild 883 BLAKE2B cc65a51ed8b8409881789e996c4fe99c7dd460743c9166a5dd21414cab92f09a35bfb78ae74422b1fdf7f4ce93dca586c9e3d407c51967997cfb840c9f379a6f SHA512 2a1b53c1a4911e94fce49828e4b15ec99692e836687eb4345fc16e5b92696ddbc209f8a564c963899f1eaf653023fa7fb5be57e9bbff48f1c8ed13b6b654434a
+EBUILD parso-0.5.1.ebuild 883 BLAKE2B cc65a51ed8b8409881789e996c4fe99c7dd460743c9166a5dd21414cab92f09a35bfb78ae74422b1fdf7f4ce93dca586c9e3d407c51967997cfb840c9f379a6f SHA512 2a1b53c1a4911e94fce49828e4b15ec99692e836687eb4345fc16e5b92696ddbc209f8a564c963899f1eaf653023fa7fb5be57e9bbff48f1c8ed13b6b654434a
MISC metadata.xml 377 BLAKE2B 0ac7d9c46c0b591fe46ff373bcb8942261cf0b819d9397500928546c4b07541c958edb116ecf1ff79f0a83c2f02784b019e7d64bd8a82bdfb397ef70fbbaa0c3 SHA512 7d719c633f81372caafbfb0a913fa455fd1d150210ea09713a0888b38d18ccae646b17bbe32a66b931016ee6e4bc826a1670a033466c945a2591e77f9d6d7b7c
diff --git a/dev-python/parso/parso-0.5.1.ebuild b/dev-python/parso/parso-0.5.1.ebuild
new file mode 100644
index 000000000000..9c33ffe3718c
--- /dev/null
+++ b/dev-python/parso/parso-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -vv test || die "tests failed with ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}