summaryrefslogtreecommitdiff
path: root/dev-python/parso
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/parso
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest2
-rw-r--r--dev-python/parso/parso-0.3.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index d41e0bd27f55..391e0c91fe23 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,3 +1,5 @@
DIST parso-0.1.1.tar.gz 376876 BLAKE2B ad0b9492273d23da1f4133a2f1e6edd2fa7f2213dbe12868f891863e9286fa0281de7fc6c6924b78a5820f94867971bbc09f18b3d0f2e4832c9c875850205254 SHA512 1199651136af1c9f0801a031a197e367f7fa73b5878b863103a506481e8b325e6b305e4260510a567dccf91f298fd7e9e5674f4dc410765ae1f9112f742aa6a0
+DIST parso-0.3.1.tar.gz 375226 BLAKE2B 71481f5f382f14e5f2c7826f8eb50a1c35f8c280f14c8bf52bcf44f77aa9872cddce7d7fb7b0a586ab7cda547e43bbce11812077ae84129c418a9f0bb3c5b856 SHA512 f83e316a41e21d3132d9ee8a45f9042962c01a2b906e8791046112b9ed938d378b0dc28c4ae05ce03a8c2d19563a49cba9a9a230654345ff62e87cc763536ddb
EBUILD parso-0.1.1.ebuild 883 BLAKE2B 8f52d4148903686b6ec51372fbe321c7eeb29fa5a3338437939c52d9aadab65a954c7b009f426f4f30d989d9383a4bc813151b1f499958eec514b220822e7b26 SHA512 cf635d907f95419e68800cac9e56db4915ac2ee290d653d884fdc8a24bf5dd7794766b8e10f6182de4d85b9246651728d53771bfd4766f15244edd20ea6f5372
+EBUILD parso-0.3.1.ebuild 886 BLAKE2B e50611c9e36743f0b30053ec0a4465f8f149f9e88449d74202ab6ca26225506adf3850dcb33df4b292ae2b6c509dd5bf02cf6b0138ecc85de7a8bc263f31a958 SHA512 76f4ffe2eb7402fd0484d29203822b0da3a0e4594020aa7c72563e9e244a3e8421af0d5de380e7b90c5f95684492b914a8c11e274e7e870888d8885df1d73192
MISC metadata.xml 377 BLAKE2B 0ac7d9c46c0b591fe46ff373bcb8942261cf0b819d9397500928546c4b07541c958edb116ecf1ff79f0a83c2f02784b019e7d64bd8a82bdfb397ef70fbbaa0c3 SHA512 7d719c633f81372caafbfb0a913fa455fd1d150210ea09713a0888b38d18ccae646b17bbe32a66b931016ee6e4bc826a1670a033466c945a2591e77f9d6d7b7c
diff --git a/dev-python/parso/parso-0.3.1.ebuild b/dev-python/parso/parso-0.3.1.ebuild
new file mode 100644
index 000000000000..b1c6a08983de
--- /dev/null
+++ b/dev-python/parso/parso-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -vv test || die "tests failed with ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}