summaryrefslogtreecommitdiff
path: root/dev-python/parso/parso-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/parso/parso-0.8.2.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/parso/parso-0.8.2.ebuild')
-rw-r--r--dev-python/parso/parso-0.8.2.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/dev-python/parso/parso-0.8.2.ebuild b/dev-python/parso/parso-0.8.2.ebuild
index 3ceece3224e7..8ab7282e6cfc 100644
--- a/dev-python/parso/parso-0.8.2.ebuild
+++ b/dev-python/parso/parso-0.8.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -17,3 +17,17 @@ KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86"
distutils_enable_sphinx docs
distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py310.patch
+)
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+ test/test_python_errors.py::test_default_except_error_postition
+ )
+ epytest ${deselect[@]/#/--deselect }
+}