summaryrefslogtreecommitdiff
path: root/dev-python/paramiko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 10:44:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 10:44:36 +0100
commit53aea9d709c9286028405b25584181507f47442f (patch)
treee7b1ada98149b1cc40791b5bb7616d133d80d46c /dev-python/paramiko
parent358368569cfce7dc6be9a6faed29805babe0e371 (diff)
gentoo auto-resync : 31:07:2023 - 10:44:36
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest2
-rw-r--r--dev-python/paramiko/paramiko-3.3.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 09518ef10bcc..e19c3c233e49 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,5 +1,7 @@
AUX paramiko-3.2.0-disable-server.patch 1771 BLAKE2B 3cab494873956d6f36b8ea85903141a49eb515fd92851f041f91418dc58acc77cdaf00a215c8e681d037d78eabfc7718a5670f2ca6af02fe357daece9a48819e SHA512 9f2f85518dec8668d096fa1db77ec5219f14fb6127c29bbdc2ba47f55e3526e9f1dbca421adb18033a8358c0efac7db723536b26bd8f45c8583503fb4ae58d76
AUX paramiko-3.2.0-nih-test-deps.patch 4289 BLAKE2B 4a77852f0ae3cda52eca8844f4bf2571c17a0935088973f48c46abf250081845a870fb52d8ebafb108f634dbe86fbe784eefd49d9240c50f911d56173d1e3d71 SHA512 4e0bed394e4c8be19108cc0a7253d6306a698a3cc09b40c18459c8e16591ff42c41cb4f385fc05dcf902161fa23ce2b7d00c665784b9106344a5ca42e4f2a788
DIST paramiko-3.2.0.gh.tar.gz 374709 BLAKE2B 80ec5678a51dc8a0eadd28228ae70a8912fb9a4be1807f5f65a925dd2252fd43ebba6f63b350b62ff7545d9ed0db6e4a78710fb73cff332e6d1ed996b0f1a7d9 SHA512 1d87a19284cef73a76eb7402d0492eb35d4a0588becd2f67ba19fe1498d6c10927127617398de11184d4865c8ce0f3e0c48194d50ef546414a17cf6faff3c39d
+DIST paramiko-3.3.1.gh.tar.gz 370001 BLAKE2B df3c82fdaeccf4aa4d10922dbdfdf8b8cd77975e7c8980b33ddb082a68dd50fd61dd3e0494f45f81c92ce3827f301bfffa4fd09e132e312de9fd490536b066bd SHA512 94ee41ceb99b0c02e455aa6a7d0fea5f88edc6e9e80dfd4d07417875bcbcc15bbef842106c7a38bae93c0e1008d99d01d7b7a026b005358ae1846a2f931f775c
EBUILD paramiko-3.2.0.ebuild 1317 BLAKE2B 2b923ef1397ac1f2d0b40303c99a2b1d116511fc48d221124f3e40f5995d1598ef0cb0cd69691fd3e7e24064a4687cab6f4479774f7f4c23c1b01fc1ab7fb89e SHA512 32c154cfcc0334c5606f469a7f184a092a3b9e5b0c34632e40e59b854c8d365d5695f4453b55ee797123a1062b4c789ea6946540e727e3c43ed18db18c8db130
+EBUILD paramiko-3.3.1.ebuild 1346 BLAKE2B 82af2821c6d1e930678c52000ef57ccc4c22f6094c3aeb9aa202bb44f79560c78363007c139bc4a1e24b901209f9ebcfdecf08a7d052be4d7839525d2890dea5 SHA512 20da71073892f5a865e35d8777d782d6cdcde512c7eb5b1816bfad7a2210e7479452ce19ba2fe62da65b8b478a4a1e46b0f8e68c996d641e821d7d9582710c66
MISC metadata.xml 1222 BLAKE2B 46fb6385f6779cbc13fa54090dd5dfa0b5a7b5a753f728b133fa79a1e1c779a5652d6b38c5ea11cfcb505178b2ba70d9000dabba6228e38f30f426ecb1c49a3f SHA512 bf07a537ed375a3bf58d219c18ccfc29c810554041943e62819a46b63ce3fbcdd2197085dbeeb7ad36e0e601700edec6121ce5cc83dce1c7435d663473df2583
diff --git a/dev-python/paramiko/paramiko-3.3.1.ebuild b/dev-python/paramiko/paramiko-3.3.1.ebuild
new file mode 100644
index 000000000000..a139730460a1
--- /dev/null
+++ b/dev-python/paramiko/paramiko-3.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="
+ https://www.paramiko.org/
+ https://github.com/paramiko/paramiko/
+ https://pypi.org/project/paramiko/
+"
+SRC_URI="
+ https://github.com/paramiko/paramiko/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples server"
+
+RDEPEND="
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # upstream doesn't really maintain the gssapi support
+ tests/test_gssapi.py
+ tests/test_kex_gss.py
+ tests/test_ssh_gss.py
+)
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-3.2.0-nih-test-deps.patch"
+ )
+
+ if ! use server; then
+ PATCHES+=( "${FILESDIR}/${PN}-3.2.0-disable-server.patch" )
+ fi
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/*
+ fi
+}