summaryrefslogtreecommitdiff
path: root/dev-python/paramiko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/paramiko
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest3
-rw-r--r--dev-python/paramiko/files/paramiko-2.6.0-tests.patch34
-rw-r--r--dev-python/paramiko/paramiko-2.6.0.ebuild64
3 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 688cb319c50f..c19ae3450a1e 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,4 +1,7 @@
AUX paramiko-2.4.2-disable-server.patch 1596 BLAKE2B 7e2ef1e216f34086c06d985556dde82eccfc08b835a9b336f1e54e81ddf32567872daec9dadc728bfaab8e3c4728439d704d51f9b1df5e04a64b5064f6d79bf5 SHA512 5e2f9285ffa3ece551ce929c6d50691761da6269e906355bbf79b0664a764083f7d55a9e347e2ed236a4c9a7f934d489315b68ebea984694ee9d1714416d34fd
+AUX paramiko-2.6.0-tests.patch 1193 BLAKE2B 86063ffd478f5772e2aacbbd6e6a74262ebaa1e67126af598eb589e49484efc15b581df0bbc796c0790a5ca80d6b5a72cbd07782c7790a9782e66f857e9c2336 SHA512 5b5de9c209d6aee83dc57f2f04d1d43f7106ed135fc12427d9237cf63932408c6385f878d02ef5dbb3d09476ee516148208d0390caa21f82a113bf6ed5a8176e
DIST paramiko-2.4.2.tar.gz 289126 BLAKE2B 767f81a09b32762241eed6661e520e3b3a96acfe8e6e638ea7ae180a8b6866f8f4adeae0a0146d46ecbfccbe71334c5f5c14e2d049744258ca4808ac21365185 SHA512 894c2ebfcfb35a84fe74670d0eb67022a49b7bf165f31acd929045c17509d8a2be111e8319f20513b5034efd033edc6432b2ca2e7027dc7e3c6703166a96790f
+DIST paramiko-2.6.0.tar.gz 304469 BLAKE2B cde861069c8924b2f685675266fd28600ffd24a39074e9ad5db8fd1d010c6e23ca13a2c78a79b23504dfff395b773b171e7c787119d01e3b92a2eec44ca8b40a SHA512 1ac2c3486cb786a1e4640d7b7f8628087f9b78ee247b09dbd3ac2646790da4f12cf95fc4291f27f200b63ec6c11d9ebf5a1283f88cf2de7c2eb6e6f76e892ef2
EBUILD paramiko-2.4.2.ebuild 1526 BLAKE2B 7ab3ec8d7d0ba9a8ee7391c1d9c410ace9be2a3717e7d91c39076518e9152395ddfe9c290afd27a68471cd209fb3934548c3043a53107057a392655dfbe530b0 SHA512 d2abb05897eaac0334a1a3ebee68521f76c666fbd5a807e79d86f5bf3eb331d4d58a1f14e13dce12ced9fe4fd03b8eaa71a4a7125a9820925e6643a9d4f42ec1
+EBUILD paramiko-2.6.0.ebuild 1667 BLAKE2B 13f04d9366f552e2e0d3fdfecbfce795ccf46a874054a2c3223e715365ba7d479e4ca15fade78ac7bfaa041df594c71a9ca8bbc2fd7bc8f72c9f2007e6943eac SHA512 90a9f57bc61661a780b154e1f7fd00b2f28e91fa40c91229e641f6a62fd0c92812ee1c0c4801f2d017fb5a9bbd7da47bfb16b38f176087d3c324466f9e0fcf56
MISC metadata.xml 1306 BLAKE2B 5bf88516d7d34aa0018b00250edddcc3d7044605e59fd9c799775043f2984a071f743994712cbdc009893a01ee9cbd60df85dcd7f644f7dd33e05a426b06391b SHA512 30bbefd00271e8a61c886e638f30aae8aa751dea4ed0e023e50e31d28d528a203c36e80c8a142573a4b39c958be84eca5c7c19986c2eaa86575ad9b3779ef0d1
diff --git a/dev-python/paramiko/files/paramiko-2.6.0-tests.patch b/dev-python/paramiko/files/paramiko-2.6.0-tests.patch
new file mode 100644
index 000000000000..4b15f6a50502
--- /dev/null
+++ b/dev-python/paramiko/files/paramiko-2.6.0-tests.patch
@@ -0,0 +1,34 @@
+Skip tests requiring pytest-relaxed since it was removed from the tree due to
+breaking pytest.
+
+--- paramiko-2.6.0/tests/test_client.py
++++ paramiko-2.6.0/tests/test_client.py
+@@ -33,7 +33,7 @@
+ import weakref
+ from tempfile import mkstemp
+
+-from pytest_relaxed import raises
++#from pytest_relaxed import raises
+ from mock import patch, Mock
+
+ import paramiko
+@@ -684,7 +684,8 @@
+
+ # TODO: more granular exception pending #387; should be signaling "no auth
+ # methods available" because no key and no password
+- @raises(SSHException)
++ #@raises(SSHException)
++ @unittest.skip("skip tests requiring pytest-relaxed")
+ def test_passphrase_kwarg_not_used_for_password_auth(self):
+ # Using the "right" password in the "wrong" field shouldn't work.
+ self._test_connection(passphrase="pygmalion")
+@@ -705,7 +706,8 @@
+ password="television",
+ )
+
+- @raises(AuthenticationException) # TODO: more granular
++ #@raises(AuthenticationException) # TODO: more granular
++ @unittest.skip("skip tests requiring pytest-relaxed")
+ def test_password_kwarg_not_used_for_passphrase_when_passphrase_kwarg_given( # noqa
+ self
+ ):
diff --git a/dev-python/paramiko/paramiko-2.6.0.ebuild b/dev-python/paramiko/paramiko-2.6.0.ebuild
new file mode 100644
index 000000000000..eaa0bb58a7ab
--- /dev/null
+++ b/dev-python/paramiko/paramiko-2.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="http://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.org/project/paramiko/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="doc examples server test"
+
+RDEPEND="
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-tests.patch
+
+ if ! use server; then
+ eapply "${FILESDIR}/${PN}-2.4.2-disable-server.patch"
+ fi
+
+ eapply_user
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx -s sites/docs
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demos/*
+ fi
+}