summaryrefslogtreecommitdiff
path: root/dev-python/pandas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/pandas
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/Manifest2
-rw-r--r--dev-python/pandas/pandas-1.3.5.ebuild198
2 files changed, 200 insertions, 0 deletions
diff --git a/dev-python/pandas/Manifest b/dev-python/pandas/Manifest
index 8dc95802f5af..e45176091dfb 100644
--- a/dev-python/pandas/Manifest
+++ b/dev-python/pandas/Manifest
@@ -1,6 +1,8 @@
AUX pandas-1.3.4-arm-tests.patch 665 BLAKE2B 0096cffbc1830005a89026e1fcf06d8e579303c676ef7da6a28b2209748bc8d716cccfb6671d60dc3eeae08cd2d305e0a0b9584ac173f01689a730a8745ca62d SHA512 be52d5e92de40af9fff06bfa9fc9b3ef6443959b92dfa72a8f0b4aa73ec2690af2162552aeb5f189ea6806146ae49ae520013f071d8c640d378ce29862ae7d74
DIST pandas-1.3.3.tar.gz 4730758 BLAKE2B 0ef945b2181329265b93fbdb7f9c35497ef847508cc2166b6e2a12ad1a2faa3940d5c8f375754ec34db4e236934a1f903f1e58e6882c6de0018a16b38f50f136 SHA512 a3a871a9954c7249311b9904e588d85fba4d6aa07463308b08b789b93a1eb63e36dac1b0d4254a5379085c05c5633ef31b615d0c60963c796dd7a33d815a5534
DIST pandas-1.3.4.tar.gz 4734599 BLAKE2B a71b5b57198defcf4f6d848f445c7112668994f089b62a6bce1028ab4ba8a9bf3adc3c393699332fb0c76818ed80164843114e68e57232c495cee03ec5e88009 SHA512 c821365b1f06d69c61b957c4768a5f86b39d97d74b0732ea0eaade9d21bca8f652e38f91f83adf2fc6488f227c75d4e5e64e8f131456e7f0a93ecfcf237190a6
+DIST pandas-1.3.5.tar.gz 4736591 BLAKE2B 7c7de1485028d7c610c5a23ca1cc98551b24e824b609b7a624469f2471bb8d3984a25db48ab7413aa7cdd0057c5c5c9f1eb2b59cfc5cbf6d30177e12e2acc7b3 SHA512 cf3f76894cae19784af6393d4a575d114b55621a3d594edd7e95ac6d5c8588a580135789c859c618acfeceeb710d2a1fdd94188a839a90be6b58af929e00a726
EBUILD pandas-1.3.3.ebuild 6405 BLAKE2B febec6c5f64825e4979d016c24d3862489f8398a75b56e2f475085e2e7b47b3e7c1f52e6f14a22dc330b596037941660c33074e1895cfc9b3f70baff2ac92a01 SHA512 9922f2a2982b8c2fbcdca8ffd60cf5af99d6dd083eb2324665eaffd6c1259d2de5edb2a04503df90a92f180faa50efef9a9364e291ae9c4a906a41f585e548dc
EBUILD pandas-1.3.4.ebuild 6682 BLAKE2B 35b9e8f4a7711542007aa3f5a2fcb6a405809b80d38ba831d7d5b1136d4cfc15ae93f92ab420051187842b7509bce59c917dcf386911c118bfa3e721cf913b38 SHA512 183696d80180fe8d68696258981717ca946a450aae9ec1bc6dcdd005c555d649dee721a4fa758bc683f2b6b52548c1f6c98db98afb2929b5481accd963adc8b0
+EBUILD pandas-1.3.5.ebuild 6584 BLAKE2B 88aaf30486e1ce49f3fb0f77d1240927f28c021ca022b252bdd981b5ebeea49ab3c4afd2acbece96c4cc968e0b897cda6556d504d151a73d0d66c8ed00fc2061 SHA512 1a8c82846804abd8ef4c048a0fa8820d85e7916f98f3496682849560d5e534091e5bfd55f6f90b94bfa46d356cb111488519bdd4339cdd690ff1623491c624bf
MISC metadata.xml 918 BLAKE2B 09b6ef472cbceaade61bfec8780ba3659838cd73f0a19b277d731db75655ac7e65d396f9fa74c19a2d5e03269c541dfe2af59296c048e77744f00bdb55295d4d SHA512 0b1fd089b0ce35a4e3408cd7224a249d427571a638961a8d63dee73b386d03b5a22e4ff085e2e548749f9fc03e9beb18317010d0b67f608dafe305bb4a87ddb2
diff --git a/dev-python/pandas/pandas-1.3.5.ebuild b/dev-python/pandas/pandas-1.3.5.ebuild
new file mode 100644
index 000000000000..68ec1d34ffd1
--- /dev/null
+++ b/dev-python/pandas/pandas-1.3.5.ebuild
@@ -0,0 +1,198 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+VIRTUALX_REQUIRED="manual"
+
+inherit distutils-r1 multiprocessing optfeature virtualx
+
+DESCRIPTION="Powerful data structures for data analysis and statistics"
+HOMEPAGE="https://pandas.pydata.org/ https://github.com/pandas-dev/pandas/"
+SRC_URI="
+ https://github.com/pandas-dev/pandas/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}/${P/_/}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE="doc full-support minimal test X"
+RESTRICT="!test? ( test )"
+
+RECOMMENDED_DEPEND="
+ >=dev-python/bottleneck-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/numexpr-2.7.0[${PYTHON_USEDEP}]
+"
+
+# TODO: add pandas-gbq to the tree
+OPTIONAL_DEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/blosc[${PYTHON_USEDEP}]
+ || (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ || (
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+ )
+ >=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/xarray-0.12.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/xlwt-1.3.0[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.1[${PYTHON_USEDEP}]
+ )
+ X? (
+ || (
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+COMMON_DEPEND="
+ >=dev-python/numpy-1.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1-r3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2017.3[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-python/cython-0.29.21[${PYTHON_USEDEP}]
+ doc? (
+ ${VIRTUALX_DEPEND}
+ app-text/pandoc
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nbsphinx[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/rpy[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ )
+ test? (
+ ${VIRTUALX_DEPEND}
+ ${RECOMMENDED_DEPEND}
+ ${OPTIONAL_DEPEND}
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pymysql[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+"
+# dev-python/statsmodels invokes a circular dep
+# hence rm from doc? ( ), again
+RDEPEND="${COMMON_DEPEND}
+ !minimal? ( ${RECOMMENDED_DEPEND} )
+ full-support? ( ${OPTIONAL_DEPEND} )
+"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" \
+ -i doc/source/conf.py || die
+
+ # requires package installed
+ sed -e '/extra_compile_args =/s:"-Werror"::' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile -j1
+}
+
+python_compile_all() {
+ # To build docs the need be located in $BUILD_DIR,
+ # else PYTHONPATH points to unusable modules.
+ if use doc; then
+ cd "${BUILD_DIR}"/lib || die
+ cp -ar "${S}"/doc . && cd doc || die
+ LANG=C PYTHONPATH=. virtx ${EPYTHON} make.py html
+ fi
+}
+
+python_test() {
+ local deselect=(
+ # test for rounding errors, fails if we have better precision
+ # e.g. on amd64 with FMA or on arm64
+ # https://github.com/pandas-dev/pandas/issues/38921
+ pandas/tests/window/test_rolling.py::test_rolling_var_numerical_issues
+
+ # weird issue, doesn't seem very important
+ 'pandas/tests/base/test_misc.py::test_memory_usage[series-with-empty-index]'
+
+ # old psycopg2 API
+ pandas/tests/tools/test_to_datetime.py::TestToDatetime::test_to_datetime_tz_psycopg2
+
+ # Internet
+ pandas/tests/io/xml/test_xml.py::test_wrong_url
+
+ # TODO: some data path problems?
+ pandas/tests/io/test_fsspec.py::test_read_csv
+ pandas/tests/io/test_fsspec.py::test_markdown_options
+
+ # Broken by Python changes
+ # https://github.com/pandas-dev/pandas/issues/44420
+ pandas/tests/io/parser/test_quoting.py::test_bad_quote_char
+ )
+
+ local -x LC_ALL=C.UTF-8
+ pushd "${BUILD_DIR}"/lib > /dev/null || die
+ "${EPYTHON}" -c "import pandas; pandas.show_versions()" || die
+ PYTHONPATH=. virtx epytest pandas --skip-slow --skip-network \
+ ${deselect[@]/#/--deselect } -m "not single" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+ find . '(' -name .pytest_cache -o -name .hypothesis ')' \
+ -exec rm -r {} + || die
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ if use doc; then
+ dodoc -r "${BUILD_DIR}"/lib/doc/build/html
+ einfo "An initial build of docs is absent of references to statsmodels"
+ einfo "due to circular dependency. To have them included, emerge"
+ einfo "statsmodels next and re-emerge pandas with USE doc"
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
+ optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
+ optfeature "for msgpack compression using blosc" dev-python/blosc
+ optfeature "Template engine for conditional HTML formatting" dev-python/jinja
+ optfeature "Plotting support" dev-python/matplotlib
+ optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-3.0.0" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
+ optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
+ optfeature "R I/O support" dev-python/rpy
+ optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
+ optfeature "SQL database support" ">=dev-python/sqlalchemy-1.3.0"
+ optfeature "miscellaneous statistical functions" dev-python/scipy
+ optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt5 dev-python/pygtk x11-misc/xclip x11-misc/xsel
+}