summaryrefslogtreecommitdiff
path: root/dev-python/pandas/pandas-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /dev-python/pandas/pandas-9999.ebuild
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'dev-python/pandas/pandas-9999.ebuild')
-rw-r--r--dev-python/pandas/pandas-9999.ebuild59
1 files changed, 33 insertions, 26 deletions
diff --git a/dev-python/pandas/pandas-9999.ebuild b/dev-python/pandas/pandas-9999.ebuild
index c29b323ee1ac..6bf3185ad30c 100644
--- a/dev-python/pandas/pandas-9999.ebuild
+++ b/dev-python/pandas/pandas-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
PYTHON_REQ_USE="threads(+)"
VIRTUALX_REQUIRED="manual"
@@ -18,40 +18,41 @@ EGIT_REPO_URI="https://github.com/pydata/pandas.git"
SLOT="0"
LICENSE="BSD"
KEYWORDS=""
-IUSE="doc -minimal full-support test X"
+IUSE="doc full-support minimal test X"
-MINIMAL_DEPEND="
- >dev-python/numpy-1.7[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- !<dev-python/numexpr-2.1[${PYTHON_USEDEP}]
- !~dev-python/openpyxl-1.9.0[${PYTHON_USEDEP}]"
RECOMMENDED_DEPEND="
dev-python/bottleneck[${PYTHON_USEDEP}]
- >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]"
+ >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]
+"
OPTIONAL_DEPEND="
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
dev-python/boto[${PYTHON_USEDEP}]
>=dev-python/google-api-python-client-1.2.0[$(python_gen_usedep python2_7 pypy)]
- || ( dev-python/html5lib[${PYTHON_USEDEP}] dev-python/lxml[${PYTHON_USEDEP}] )
+ || (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
- || ( >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}] dev-python/xlsxwriter[${PYTHON_USEDEP}] )
+ || (
+ >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+ )
>=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
dev-python/python-gflags[$(python_gen_usedep python2_7 pypy)]
dev-python/rpy[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
dev-python/xlrd[${PYTHON_USEDEP}]
dev-python/xlwt[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
X? (
|| (
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-python/pyside[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
dev-python/pygtk[$(python_gen_usedep python2_7)]
)
|| (
@@ -59,13 +60,18 @@ OPTIONAL_DEPEND="
x11-misc/xsel
)
)
- "
-
-DEPEND="${MINIMAL_DEPEND}
+"
+COMMON_DEPEND="
+ >dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/cython-0.23[${PYTHON_USEDEP}]
doc? (
${VIRTUALX_DEPEND}
+ app-text/pandoc
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
@@ -91,23 +97,24 @@ DEPEND="${MINIMAL_DEPEND}
dev-python/psycopg:2[${PYTHON_USEDEP}]
x11-misc/xclip
x11-misc/xsel
- )"
+ )
+"
# dev-python/statsmodels invokes a circular dep
# hence rm from doc? ( ), again
-RDEPEND="
- ${MINIMAL_DEPEND}
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/numexpr-2.1[${PYTHON_USEDEP}]
+ !~dev-python/openpyxl-1.9.0[${PYTHON_USEDEP}]
!minimal? ( ${RECOMMENDED_DEPEND} )
- full-support? ( ${OPTIONAL_DEPEND} )"
+ full-support? ( ${OPTIONAL_DEPEND} )
+"
python_prepare_all() {
# Prevent un-needed download during build
- sed \
- -e "/^ 'sphinx.ext.intersphinx',/d" \
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" \
-i doc/source/conf.py || die
# https://github.com/pydata/pandas/issues/11299
- sed \
- -e 's:testOdArray:disable:g' \
+ sed -e 's:testOdArray:disable:g' \
-i pandas/tests/io/json/test_ujson.py || die
distutils-r1_python_prepare_all
@@ -159,5 +166,5 @@ pkg_postinst() {
optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
optfeature "SQL database support" ">=dev-python/sqlalchemy-0.8.1"
optfeature "miscellaneous statistical functions" sci-libs/scipy
- optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt4 dev-python/pyside dev-python/pygtk x11-misc/xclip x11-misc/xsel
+ optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt5 dev-python/pygtk x11-misc/xclip x11-misc/xsel
}