summaryrefslogtreecommitdiff
path: root/dev-python/pandas/pandas-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-20 11:40:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-20 11:40:01 +0000
commitd6ecedbb65041ed35010095376e87dd7de4270c5 (patch)
treef00964f121a5ec52d2f3d1fd00a8f3eb52f9c756 /dev-python/pandas/pandas-2.2.0.ebuild
parent89a009d7439343e207e8c7e4df1a28adecafeffe (diff)
gentoo auto-resync : 20:02:2024 - 11:40:01
Diffstat (limited to 'dev-python/pandas/pandas-2.2.0.ebuild')
-rw-r--r--dev-python/pandas/pandas-2.2.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pandas/pandas-2.2.0.ebuild b/dev-python/pandas/pandas-2.2.0.ebuild
index cd8aaac786dc..fffb8d3f5f38 100644
--- a/dev-python/pandas/pandas-2.2.0.ebuild
+++ b/dev-python/pandas/pandas-2.2.0.ebuild
@@ -49,10 +49,8 @@ OPTIONAL_DEPEND="
>=dev-python/xlsxwriter-3.0.3[${PYTHON_USEDEP}]
>=dev-python/xlwt-1.3.0[${PYTHON_USEDEP}]
!x86? ( !hppa? (
- $(python_gen_cond_dep '
- dev-python/statsmodels[${PYTHON_USEDEP}]
- ' python3_{8..10} )
>=dev-python/scipy-1.8.1[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
) )
X? (
|| (
@@ -176,8 +174,18 @@ python_test() {
# requires pyarrow (which is really broken)
tests/io/formats/style/test_bar.py::test_style_bar_with_pyarrow_NA_values
tests/series/test_api.py::TestSeriesMisc::test_inspect_getmembers
+
+ # assumes that it will fail due to -mfpmath=387 on 32-bit arches,
+ # so it XPASS-es in every other scenario
+ tests/tools/test_to_timedelta.py::TestTimedeltas::test_to_timedelta_float
)
+ if ! has_version "dev-python/scipy[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/plotting/test_misc.py::test_savefig
+ )
+ fi
+
local -x LC_ALL=C.UTF-8
cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -c "import pandas; pandas.show_versions()" || die