summaryrefslogtreecommitdiff
path: root/dev-python/paho-mqtt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/paho-mqtt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/paho-mqtt')
-rw-r--r--dev-python/paho-mqtt/Manifest6
-rw-r--r--dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch29
-rw-r--r--dev-python/paho-mqtt/metadata.xml15
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.1.ebuild16
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild37
5 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
new file mode 100644
index 000000000000..d3bd1be41c3c
--- /dev/null
+++ b/dev-python/paho-mqtt/Manifest
@@ -0,0 +1,6 @@
+AUX paho-mqtt-1.3.1-strip-test-dependency.patch 681 BLAKE2B 0ed9a448e5e72813aa05ad1d37ae957150ad09b6d48a54f668a969e5e98ad25f8d55b223064e01f6773d0e42da3ba26f2e0a7f43a628ff68fee4b619b8de96c9 SHA512 dbadb8c1bd7691a973d8c1cd146ac9bd72407625ddfc5042b25bc81ff74af6d554c06fa3b2972637acc4a466e75a65c9371990e43bbf649fe5a5a22da2bb36fb
+DIST paho-mqtt-1.1.zip 159529 BLAKE2B ca3a39628c9cab8c4f3606587a5c853e79535b37a92991ecc32903967952cc00f6a9b967af0d343c4619f3e46ace1330baebc7c2e9dc231673f51775e4e1de25 SHA512 ef6d1a29480671413dbb655bd8f668b99f8587c14589d2180a37142b368e0ce058f8ed967dbfaa82f239c86e295338bc35c9f28a3ea39d21a6034cd8787a63ce
+DIST paho-mqtt-1.3.1.tar.gz 102133 BLAKE2B 905a51824d487cb125e06114bcba6b1ba862de4ab816db16aadb6ff761145fd4724dc6523a0c6837b8a16ced6730c5558612deb138bd95721f15054f5d6851a4 SHA512 95adeeaffbbd4b39d19fbd46feb39ec4a2ac923addd3c754a474b7a91d620bfca1678645c1a09c925e38a33995575944b873e3b2300d7bc2f3c5be3005c74d4c
+EBUILD paho-mqtt-1.1.ebuild 499 BLAKE2B 43da38aa5822daa6968d4a7b9514ddb86d0297617c59caede2453fe0d96ab29daa11c3ef6a38d9bda79c4f1133901b1eb4f2b6752b54162b684c63dca76f60f8 SHA512 b9c0957e161058d9594f7516fb31b2f45168a55fca7780b84e2ca695eb37b5acda3bee064fe2d4f3f603586565c2f806521123844f84924f325b75f9743eb928
+EBUILD paho-mqtt-1.3.1.ebuild 833 BLAKE2B 5363c1872085058e86c8dde20d56db395b34aac97f673d3e11749fe9945c1c3d28582128e2b3c69540e69cf26ab9498113fd1414ca1d17659f41f463bb64ee5f SHA512 4f5c9188b6cd1729ec53d12e0bc56a25251cf0468fb73464acfd3a1cf39faf885cbfbec3a951fb222fb862136e61879e3adfe5f80ee3eafd862b34d666abdfb3
+MISC metadata.xml 462 BLAKE2B bb478b5d843359050dbdb5ba67e9bca36dec28f6c65b6e89ac49cc00cf63c80abebc4525de91bd0c43f6979bc2c1a3b850243de39f3d5620a1f19d6b3c9fb8dd SHA512 bb6dabe3f0a5dcda951a9aa58ae0c883ceb7324f8538dd2962fbe216eeedf9af09829b79e35f5bbd8baa00cdfd16602411430276329554bb1908d6ca9609a9ae
diff --git a/dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch b/dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch
new file mode 100644
index 000000000000..0cb9750a6f54
--- /dev/null
+++ b/dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch
@@ -0,0 +1,29 @@
+# Remove Pylama from test dependencies.
+
+diff --git a/setup.cfg b/setup.cfg
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,9 +1,6 @@
+ [aliases]
+ test=pytest
+ [tool:pytest]
+-addopts=-r xs --pylama
++addopts=-r xs
+ strict=True
+ testpaths=tests src
+-[pylama]
+-linters=pyflakes
+-skip=tests/*
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ with open('README.rst', 'rb') as readme_file:
+ readme = readme_file.read().decode('utf-8')
+
+ requirements = []
+-test_requirements = ['pytest', 'pylama']
++test_requirements = ['pytest']
+ needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
+ setup_requirements = ['pytest-runner'] if needs_pytest else []
+
diff --git a/dev-python/paho-mqtt/metadata.xml b/dev-python/paho-mqtt/metadata.xml
new file mode 100644
index 000000000000..c1efb3bd1df1
--- /dev/null
+++ b/dev-python/paho-mqtt/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ramage.lucas@openmailbox.org</email>
+ <name>Lucas Ramage</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eclipse/paho.mqtt.python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.1.ebuild
new file mode 100644
index 000000000000..f91a9e34c585
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1 on Python 2.7 or 3.x."
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/${PV}.zip -> ${P}.zip"
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild
new file mode 100644
index 000000000000..6017730c61e7
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ ) "
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+RESTRICT="test" #659106
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-strip-test-dependency.patch"
+ default
+}
+
+python_test() {
+ esetup.py test
+}