summaryrefslogtreecommitdiff
path: root/dev-python/paho-mqtt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/paho-mqtt
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/paho-mqtt')
-rw-r--r--dev-python/paho-mqtt/Manifest2
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index 259e83442d59..9cc623706b5a 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1,4 +1,6 @@
AUX paho-mqtt-1.5.0-strip-test-dependency.patch 801 BLAKE2B ae44e567fea5cb08d116790191a69899c95714db4e76735fc4658174e37595b8a354e8c5fc470c035833fe3b7d27a6e47e7db77db0bab1884306144ca69379ff SHA512 aebc29ede887b5818718a56e933e9ac2342478b528f82b9d72b1132138ddbd2c97b3be2f1e5dadadec38cabf793818c6f55ea16b44336f4a40c8295b9cea0602
DIST paho-mqtt-1.5.0.tar.gz 126869 BLAKE2B 2dce27c1fcfe7ae422dc6da76fb58e7901de00c0c349b9715c56a3603da26e1f46af9bb8c0bd982043ba54a2070655b483d251a0a847e1c3afb36bcd4cfcdba8 SHA512 7e52180bf1783ee1f39aa5248730e82fae47fe3db7c4579b0b7207a29f5337c7c0af58d58aac1c265b1ed91fa9c240187d5e3005f55c6e28623e6cbc36750294
+DIST paho-mqtt-1.5.1.tar.gz 144740 BLAKE2B 1c218f1109476fe9b28c26e1113717448377c53a2b9e01437f93d4a29f77e3b61f59492c263f160825ddcce25f907dbf72d3078954cc378d4846afb435d79bba SHA512 7e686bcc702f70c45ab061aa9833d42c4356d5002d27a035a685ca384a5b7d5e9dfd88ac95183816e08dd131463582707acd1d2e0f6de0f7dbbb6a6d0a615c97
EBUILD paho-mqtt-1.5.0.ebuild 740 BLAKE2B f07a45db3985811ee14680056c398ebb6a46798831eede1cd6e295c78e62d506f4907c111b5063b659b741557928ea95af87685fb215cd03c9005aabd0e26aea SHA512 bdf6026fad5ab85c81b74af6be1523ee740d09fff3718ce55820e08743dfe04e1b40df20a3d79e0901ee26a9e7aa9f41208c4b2924f4e424c02143abb972b9a8
+EBUILD paho-mqtt-1.5.1.ebuild 786 BLAKE2B ad1272ce4bff477c7f463a991e234366d6309099fa6ed8416aa4f42256fcb0dd354e3769b84157969b8d98932d1071e9630de3e42ac5b185ea7613b9f3e94331 SHA512 79033bfe268bef1b9da471ace0d61a1ca7796dbaf912f4e58b91ae19e8fc3d9a43e917f5dc70eedddee78e4c431f32c00cf3515af13659037fba0ff9985b2b1c
MISC metadata.xml 382 BLAKE2B 4b8014f52a3e0dc85819059010281ac9a570f2518c213697f736153333330ed616069f1b34810b9e74b600cccb2762089b9f81b8b04882dd6fdacd52f2817921 SHA512 8aa74f0eb6cb5a6d0cf897bc87514263cfb417634d76aae4299facab44eab8f199d31288e6bfe5f8c6a473f4c647dac9545b1215d6a66af17fb8a4b06dcb9a9f
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild
new file mode 100644
index 000000000000..ba6f3e2ee05f
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for MQTT v5.0, v3.1.1, and v3.1"
+HOMEPAGE="https://www.eclipse.org/paho/index.php?page=clients/python https://github.com/eclipse/paho.mqtt.python"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-strip-test-dependency.patch"
+)