summaryrefslogtreecommitdiff
path: root/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild')
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild
new file mode 100644
index 000000000000..42851e9557cc
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for MQTT v5.0, v3.1.1, and v3.1"
+HOMEPAGE="https://www.eclipse.org/paho/index.php?page=clients/python https://github.com/eclipse/paho.mqtt.python"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+LICENSE="EPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+distutils_enable_tests pytest