summaryrefslogtreecommitdiff
path: root/dev-python/packaging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
commitb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (patch)
treed67748047921162af2742c3e1255e3f1421f769b /dev-python/packaging
parent76617568771869151cb2a3f71939719c15dd47a2 (diff)
gentoo auto-resync : 24:07:2023 - 14:55:44
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest2
-rw-r--r--dev-python/packaging/packaging-21.3-r2.ebuild50
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 49c22d14032d..acc5193e0baa 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,5 +1,3 @@
-DIST packaging-21.3.gh.tar.gz 80471 BLAKE2B a16ba1e74f0c868816131a7cb07b7aa0c14760cf3ad4c3d6737ac30ef99276c33b1f018d29e710f28e8d0cfb0e3e6b91e375d1d17e2b7ec6302164377cd503d0 SHA512 8960deacda26877b73d98a3b632e760e902a16ec7a04707f84044980e4d4fb33e4f584db115c9008066aa876079f28633bafe37fbd5ce9a23830b6b89eb4ae7a
DIST packaging-23.1.tar.gz 134240 BLAKE2B ef7ef320a98592769078581e32fcc355d05f6fbb7611e7bd83fd2ed64d5f5f5d9c1f89c2a4a91ace1221214a9047e233d8d6a339fd29066b3695137ec5a870bd SHA512 0f2246b8bfeb467623ee72e6fdb7c0416e3b4ba0e00102c1528581e0835cc8e731a812b15e2e429d3ebb0001713d95cc2675f443f4597b092e305a3ef2e9137a
-EBUILD packaging-21.3-r2.ebuild 1243 BLAKE2B 1a720ba1ffd5a5e62d37de77d9e4753440f82ca79df6f336ec5ebcc3e19d54dfab333c4ea1c78576ceef34d1a047a0b06844a882d98d04cf85f60840b8f704f9 SHA512 7b7dda9e0e74f5fbb332477c90abdcd57c6788c069c731c4c880bce51ea07f42e0f8b2345b419832a3a788f3c2dfa07cbd9287ab04ca2d9ca6f280a0b7e5b89a
EBUILD packaging-23.1.ebuild 842 BLAKE2B 2506aee907cc294813a66b275016285090ae73e5d801f9abb40a11fd037db34c70b993c1111e977ff8edc928587a017a532255782622a394bd4d571013561e32 SHA512 70cdd653a904eeee80fdedcbaceb5ea63009407a7e2c14322ca8261483cf76540bc851859cbbdd62a5f25b7220f4a3d7076530b7d7399e8b235c8fe1dc584b0e
MISC metadata.xml 391 BLAKE2B 0d73ed3809b26e3069048116ab247ceeb9e2932e0d8d6063b97cc1f0ed8359e73a54b22035fedb169524e502b6a07b8203e6c35d801f738bbed685d90e12bf96 SHA512 eb4d1ca476a45232547fdd961a4e6715dda24c7ab82e1f1995ac977b9825793d5d10a2ac408b1ee0b7c8b8444f2c42be33d6fb1012461f96db9a71477cca67ae
diff --git a/dev-python/packaging/packaging-21.3-r2.ebuild b/dev-python/packaging/packaging-21.3-r2.ebuild
deleted file mode 100644
index 45aaeb4424a7..000000000000
--- a/dev-python/packaging/packaging-21.3-r2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="
- https://github.com/pypa/packaging/
- https://pypi.org/project/packaging/"
-SRC_URI="
- https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- >=dev-python/pyparsing-3.0.7-r1[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "packaging"
- dynamic = ["version"]
- description = "More routines for operating on iterables, beyond itertools"
- EOF
-}
-
-python_test() {
- epytest --capture=no
-}