summaryrefslogtreecommitdiff
path: root/dev-python/packaging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-04 23:42:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-04 23:42:56 +0000
commit7b43cd44c0c26cd9e0ae1dcd94596667cb119ee6 (patch)
tree9715703a1ec2185bfa303bd2d2b04e560654f72a /dev-python/packaging
parent27ad6a285576ce16e4c74d806efee77166f0c3c6 (diff)
gentoo auto-resync : 04:02:2024 - 23:42:56
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-23.2-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 129080d96b12..0bb111c46c68 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,3 +1,4 @@
DIST packaging-23.2.tar.gz 146714 BLAKE2B cf7986a07312fd82a2a0ee738088993b9570d95cd0b573afa7a1f911bf335de7084e3d40d961adea7f5a8369738688f9d0a4265ef26a393f2d30769bc13f752a SHA512 8ab5e9bc4feef2fac1c9044dc8a6f2d41aaf9fe2dae671de8b98c0b1a19dca2169588b87d85a8c990d808b1e76faee65984ce970eaa3282b75e107ca82cc2863
+EBUILD packaging-23.2-r1.ebuild 799 BLAKE2B e697bb27a24e0ba08bb4bcd70771d716085f47b9061229a563659e42a6e778ff9f4e879b7c6ebd8e3eba7f471de4b757e91acc23946a76355e93d86358805b5f SHA512 9af51d677b174dbaabaec1946b616cad609cd7ff2f07342304165f9d5074b4cd74e19615bbc40e3f01506700615d3a92f7e5feceb6ae579de79a9a5338d1084f
EBUILD packaging-23.2.ebuild 842 BLAKE2B 2506aee907cc294813a66b275016285090ae73e5d801f9abb40a11fd037db34c70b993c1111e977ff8edc928587a017a532255782622a394bd4d571013561e32 SHA512 70cdd653a904eeee80fdedcbaceb5ea63009407a7e2c14322ca8261483cf76540bc851859cbbdd62a5f25b7220f4a3d7076530b7d7399e8b235c8fe1dc584b0e
MISC metadata.xml 391 BLAKE2B 0d73ed3809b26e3069048116ab247ceeb9e2932e0d8d6063b97cc1f0ed8359e73a54b22035fedb169524e502b6a07b8203e6c35d801f738bbed685d90e12bf96 SHA512 eb4d1ca476a45232547fdd961a4e6715dda24c7ab82e1f1995ac977b9825793d5d10a2ac408b1ee0b7c8b8444f2c42be33d6fb1012461f96db9a71477cca67ae
diff --git a/dev-python/packaging/packaging-23.2-r1.ebuild b/dev-python/packaging/packaging-23.2-r1.ebuild
new file mode 100644
index 000000000000..4d07f6ea8577
--- /dev/null
+++ b/dev-python/packaging/packaging-23.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/
+"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/setuptools-67
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}